2

I have recently upgraded my laptop from Debian Jessie to Stretch.

X server stopped working. The laptop's Nv card is Gforce GT325M. The original driver I use with Jessie is installed via Nvidia's installer instead of Debian apt.

I tried to reinstall with the same installer. It didn't work. I also tried Debian packaged drivers. uninstalling Nvidia driver, installing nvida-legacy-340xx-driver pacakge. together with xserver-xorg-video-nvidia-legacy-3

None of them worked for me, all resulting the same error in /var/log/Xorg.0.log 'Failed to load module 'nvidia' (module does not exist, 0)'

I can see nvidia module loaded in lsmod output.

lsmod | grep nvidia
nvidia 9506816 0
drm     253952 2 nvidia

greping for the kernel modules gives this:

find /lib/modules/4.9.0-3-686-pae/|grep nvidia
/lib/modules/4.9.0-3-686-pae/kernel/drivers/net/ethernet/nvidia
/lib/modules/4.9.0-3-686-pae/kernel/drivers/net/ethernet/forcedeth.ko
/lib/modules/4.9.0-3-686-pae/updates/dkms/nvidia-legacy-340xx.ko
/lib/modules/4.9.0-3-686-pae/updates/dkms/nvidia-legacy-340xx-uvm.ko

after installing the Debain packaged driver. I noticed that the nvidia alternative for GLX has disappeared.

update-alternative --query glx
name: glx
link: /usr/lib/glx
.....
status: auto
best: /usr/lib/mesa-diverted
...
alternative: /usr/lib/mesa-diverted

there is no nvidia related entry. I remember when I use nvidia installer, the nvidia alternative was there and was chosen. but that didn't make any change to the startx failure and the error message in xorg log.

The xorg.conf file is ok. the original one left in my user directory when Jessie was still kicking and the nvidia-xconfig generated in '/etc/X11/xorg.conf' looks the same like below:

serverlayout "layout0"
    screen "screen0"
        monitor "monitor0"
            ventorname "unknown"
            modelname  "unknown"
            vertrefresh 43.0-72.0
            option "dpms"
        device "device0"
            driver "nvidia"
            vendorname "nvidia corperotion"
        default colordepth 24
    ...

I have never troubleshoot X related issue before. Thanks in advance.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.