0

I started a deepstream server in a vagrant vm. The server says it's

Listening for websocket connections on 0.0.0.0:6020/deepstream

The /etc/hosts in the vm:

# 0.0.0.0   localhost
127.0.0.1 localhost
# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

When I curl the deepstream server from within the vm, I get

curl 'http://0.0.0.0:6020/deepstream'
curl: (52) Empty reply from server

I tried starting the server with localhost, 127.0.0.1, and 0.0.0.0. I also tried curling these three addresses to no avail.

1 Answer 1

0

Listening on 0.0.0.0 means listening on all local IP addresses.

Try curl http://127.0.0.1:6020/deepstream to access it from the VM itself. Or use any other IP address on your VM - a non-localhost IP address is required if you want to access it from another machine (including the VM's host). Or any hostname that resolves to any of the IP addresses on your VM.

If your VM doesn't have any other IP addresses then that's a problem you need to solve if you want to access any network services on it from outside the VM. That's beyond the scope of this question, post a new question with details of your VM's setup (including vagrant config, and local dhcp server if any)

Note: It is a good idea to monitor the deepstream server's log file in another terminal, e.g. by running tail -f and then trying to connect, at least while you are debugging the initial setup (or any other time when there are problems).

BTW, you should get rid of the 0.0.0.0 entry in /etc/hosts and uncomment the 127.0.0.1 entry. 0.0.0.0 is NOT localhost and it is not a synonym for localhost.

2
  • Thank you for your reply. I modified /etc/hosts, as suggested. I modified the deepstream config to listen on 127.0.0.1. But a curl inside the VM to this address still results in the described error. There are also no entries for the curl when I monitor the deepstream log.
    – reggie
    Jul 22, 2017 at 6:28
  • Listening on 0.0.0.0 is not a problem - that just means "listen on all IP addresses". Trying to connect to 0.0.0.0 won't work, as i said you connect to one of the VM's actual IP addresses (including localhost/127.0.0.1). Now that you know that, you can stop wasting time and start investigating the real problem - finding out why deepstream isn't doing what you expect. if the config file for it has any option to enable or increase logging level, try doing that and then restarting deepstream. Also, is that URL supposed to provide a response or are you supposed to append a query or something?
    – cas
    Jul 22, 2017 at 8:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.