12

I'm pretty happy with AWN and need no native XFCE panels. I've removed all of them but can't remove the last one remaining. Is there a decent way to do it?

0

9 Answers 9

9

killall xfce4-panel, then save the session to prevent xfce4-panel from starting again.


EDIT: A 'cleaner' way would be to create a ~/.xinitrc and start everything maunally(ie: xfwm4, xfsettingsd, etc). startxfce4 starts xfce's sessions manager which in turn, starts all that stuff like xfce4-panel that you don't want.

You could also edit /etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xfce4-session.xml or ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-session.xml and comment out or delete the xfce4-panel part, but that is just doing the very same thing xfce4's session saving does via a text file.

3
  • Thank you for the answer but I don't like to use session saving facility. I'd appreciate a cleaner way to disable xfce4-panel.
    – Ivan
    May 14, 2012 at 19:22
  • Not sure of your definition of 'cleaner', but i added more infomation.
    – llua
    May 15, 2012 at 19:49
  • In Debian 10, I do have the "panel" mentioned in /etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xfce4-session.xml . But, commenting out the relevant XML object does not prevent xfce4-panel from starting. Note that it is not mentioned in my personal ~/.config/.../xfce4-session.xml . ps -aef --forest shows that the xfce4-panel binary is a child of the xfce4-session binary. The only solution probably is, to clobber the panel binary. If there was an option to auto-hide the panels including every last pixel, I would not have to kill and bury the panel binary.
    – frr
    Jan 8, 2020 at 18:43
6
sudo apt-get remove xfce4-panel
1
  • This answer currently has a score of 6, suggesting it is a good answer. But a comment on the question says that removing the xfce4-panel package will “hose your system”, suggesting this is a bad answer. That comment does not give any explanation, and I could not find any explanation elsewhere. What is going on? Jan 17 at 10:31
6

You can't delete all panels, the right way of doing this is disable it from autostart.

Edit /etc/xdg/xfce4/xinitrc , find the line to start xfce4-panel ,

enter image description here

Comment it out by placing a # in front of it , here , change the line 169 to #$panel , that will solved your issue.

When you want to re-enable panel, just remove the # at that line.

2
  • This file doesn't have that line on my debian 8 install. It does have the $panel\n ret=$?\n while... however... Feb 14, 2016 at 16:15
  • In my Debian 10, the line highlighted in your screenshot is already empty, but even if I set pane="no" beforehand, the panel still starts. ps -aef --forest shows that the panel is nowadays started by xfce4-session, rather than by the xinitrc script.
    – frr
    Jan 8, 2020 at 18:38
2

The only way I managed to get rid of the panel is to execute sudo chmod a-rwx /usr/bin/xfce4-panel

1
  • This is the solution I ended up with. Alternatively, I could've renamed the binary to some other name and add a shortcut somewhere, to be able to start the panel on demand if I ever feel lonely for it...
    – frr
    Jan 8, 2020 at 18:34
0

At the very least, if you cannot remove the last panel from the Panel Preferences, then you can make it as small as possible, move it to the screen's edge and select "Automatically hide and show panel" and Lock Panel. That should minimize the real estate it uses. When I do that with a new panel, I get so rectangle in the corner of the screen that opens to the size of the mouse when I hover over it.

0

I wasn't able to easily remove it, but I did make it invisible. In my case I wanted to be able to make the screen completely empty. I changed the desktop background to black, removed all of the desktop icons, and put the last panel in the upper left corner of the screen. I enabled the "always hide" option in the panel and set the background of the panel to match the desktop. The panel has a single item to enable easy log out. So if I move the mouse to the upper left I can see the logout button but otherwise the screen is completely empty.

0

If what you seek is just get it out of your way, you can always move the Enter & Leave Opacity of the remaining panel @ 0.

0

This answer was inspired by llua’s answer and verified on Debian 10.

Open the session settings (eg desktop context menu → Applications → Settings → Session and Startup → Session) and change the “restart style” for xfce4-panel to “Never”. There is no need to save the session. Log out and log back in, and you should see no panels.

2
  • After trudging through a solution for disabling the xfce4-panel for quite some time, this is the solution that finally worked for me. I'm not sure how it can be done outside of the GUI, as modifying xfce4's settings is a bit painful, apart from the answer above which changes permissions with chmod so that the it is unable to run. Thanks for a clean fix! (fyi: I'm using xfce out of laziness for scaling and other system functionality, but wanted to remove its panel in favor of my own status bar.)
    – mncz
    Mar 14 at 8:42
  • Update: It actually didn't work -- it broke my session cache, which then had to be manually deleted in a tty. For reference, I'm using Manjaro with XFCE. I did figure out a solution, which I'll post elsewhere in this thread.
    – mncz
    Mar 14 at 11:33
0

My workaround to stop the loading of the panel entirely ended up following along with both @llua and @daisy's answers on this thread. I wanted the panel gone having created my own polybar.

On Manjaro with XFCE, I was able to get things working as desired by editing the XML file in question. As others have noted, the panel is no longer (at least on my Manjaro system) configured in (any instance of) xinitrc. The solution was to delete three lines in /etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xfce4-session.xml which defined the property responsible for introducing the panel (lines 21-23 in my original file):

 21       <property name="Client2_Command" type="array">
 22         <value type="string" value="xfce4-panel"/>
 23       </property>

After removing these three lines (requires chmod to make it +r, and sudo) and rebooting, I logged in with the desired behavior -- finally. (One could also comment them out, I cp'd the file first.)

Note that @llua says editing this file amounts to the same thing as editing the property in xfce4-session-manager's Session and Startup menu, this isn't the case. @Brian Drake had a solution -- changing the restart style of xfce4-panel to "Never". See my comments there, but this totally broke my Xsession, requiring a manual delete of the cache in a tty to be able to even load XFCE again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.