3

This question already has an answer here:

Every-time I have to install a new Debian Linux system I encounter the same troubles with locales -- I do precisely want English system language with standards set to the country where I live, i.e. Germany.

The debian installer, and probably others, is asking at installation time for your "preferred" language. And every time I choose English. But then, I cannot add the standard locales of my country, because only English speaking countries are shown for the previously chosen language.

It's clear. After installation with enough manual fiddling it's achievable. And there is also a workaround (at least for European-ish users) by using en_IE.UTF-8 or en_DK.UTF-8 described here. However, this doesn't answer the question: Why it is so difficult to combine the preferred English system language with specific locales? I want to understand the reason/s and if there are any risks.

(Why do I want this? Because I can't see any advantage in (partially) traduced messages and software. Even more, it is much harder to find help when researching with English-foreign errors and messages got for the encountered issues.)

My actual configuration, AFAIK it works fine:

$ locale
LANG=en_US.UTF-8
LANGUAGE=
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY=de_DE.UTF-8
LC_MESSAGES="en_US.UTF-8"
LC_PAPER=de_DE.UTF-8
LC_NAME=de_DE.UTF-8
LC_ADDRESS=de_DE.UTF-8
LC_TELEPHONE=de_DE.UTF-8
LC_MEASUREMENT=de_DE.UTF-8
LC_IDENTIFICATION=de_DE.UTF-8
LC_ALL=

marked as duplicate by Gilles, Stephen Rauch, mdpc, derobert, Anthon Jul 22 '17 at 8:42

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • sudo locale-gen de_DE.UTF-8 and then logout and login again and try export LC_ALL=de_DE.UTF-8. Does it work? – user996142 Jul 21 '17 at 21:07
  • @user996142 Thank you. According to Debian locales documentation LC_ALL=... will "override all other locale variables". This is precisely what I do NOT want. I do want to keep the system language to English (US or UK). – alex Jul 21 '17 at 21:29
  • LC_ALL overwrites all LC_ but not LANGUAGE nor LANG. And you can always set it explicitly. I mean you can do export LANG="en_GB.UTF-8" – user996142 Jul 21 '17 at 21:35
  • @user996142 LC_ALL overwrites everything except some aspects of LANGUAGE. In particular, if LC_ALL is set, LANG is ignored. – Gilles Jul 21 '17 at 23:13
  • The problem is not due to your selection of locale settings. You'd have the same problem with LANG=de_DE.UTF8. It's due to missing system files which need to be generated with locale-gen. – Gilles Jul 21 '17 at 23:15