0

I'm automatically installing a bunch of packages in Ubuntu and I noticed that it is prompting for user input via whiptail on the CLI. I end up killing that process so it can progress, but that actually causes problems with the installation. I'm running apt-get install -qq . Is there a way to go with the default options and bypass these whiptail prompts?

  • 1
    Possibly related: Stop interactive prompts from apt-get (although actually the dialogs are probably from debconf rather than apt-get) – steeldriver Jul 21 '17 at 18:35
  • Yes, that looks about right, let me try it. – Walter Jul 21 '17 at 18:40
  • Hmm, still a no go. I'm inducing the problem because I've already modified the configuration files prior to installing the application / package. In any case, I want to keep my version of the configuration file and according to the command line options, -qq should do it. For example, I'm running: DEBIAN_FRONTEND=noninteractive apt-get install -qq cryptsetup,and I still get the prompts – Walter Jul 24 '17 at 1:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.