2

I'm using Linux Mint 12. There I have several partitions which I auto-mount on startup. pysdm says that /dev/sda6 should permit execution of binaries. Also the /etc/fstab says it should.

/dev/sda7   /media/Data         btrfs  users,user           0  0
/dev/sda8   /media/LocalBackup  btrfs  users,user           0  0

But executing scripts that are on this said partition yield "Permission denied". Also mount says "noexec", even though that's not specified neither in fstab nor pysdm.

/dev/sda7 on /media/Data type btrfs (rw,noexec,nosuid,nodev)
/dev/sda8 on /media/LocalBackup type btrfs (rw,noexec,nosuid,nodev)

Where is the error? Is there a further file that influences partition mounting?

4

I believe that, as a security feature, anything with user in the fstab is automatically mounted noexec unless exec is explicitly given in the fstab.

  • I deleted both user and users from the fstab, now it is only mounted rw. Thanks! – Michael Kohler May 5 '12 at 15:47
  • I'm using the 'Disks' tool on Ubuntu (via the GUI) and was able to simply add the exec option. That seems to of prevented the noexec which user option adds. – James May 1 '18 at 18:30
0

Using the option user and mounting with root privileges, will add options such as noexec, nosuid and nodev.

Mounting as a regular user, everything is fine.

So, either remove user or add the option noauto. Also, you can append the options exec and suid to a user. however, this is not recommended for security reasons.

user Allow an ordinary user to mount the filesystem. The name of the mounting user is written to the mtab file (or to the private libmount file in /run/mount on systems without a regular mtab), so that this same user can unmount the filesystem again. This option implies the options noexec, nosuid, and nodev (unless overridden by subsequent options, as in the option line user,exec,dev,suid).

noauto Can only be mounted explicitly (i.e., the -a option will not cause the filesystem to be mounted).

more details can be found in man mount

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.