1

Trying to use mozc with uim, I installed

apt-get install uim-utils mozc-utils-gui uim-gtk3

(mozc-server automatically installed) and following this suggestion, further ran

sudo uim-module-manager --register mozc

but it says

Warning: Module mozc is not a correct module.

and uim-pref-gtk3 app still doesn’t list mozc in either the enabled or disabled input methods list.

I’m doing all this on Gallium OS 2.1 which is based on Ubuntu 16.04.

  • mozc officially supports only ibus, so the special uim-mozc package is needed providing the additional /usr/lib/x86_64-linux-gnu/uim/plugin/libuim-mozc.so file. While the Arch wiki page refers to the AUR package, for Ubuntu it’s available only in trusty or after zesty. The solution would be to install it from one of those other releases. Some dependency issues are still hindering me in installing it from trusty and the one from zesty has some runtime libprotobuf version issues. – Yushin Washio Jul 23 '17 at 18:15
  • Installing uim-mozc does work if you first specifically apt-get install -t trusty mozc-server, but the issue is rather the same as for installing it from zesty: although it installs the correct libprotobuf as a dependency, it reports "This program ... is not compatible with the installed version (2.6.1)" of the Protocol Buffer runtime library (the one that was previously installed and is still installed alongside the one newly installed for uim-mozc). I’m afraid one needs to completely switch to zesty or make a custom build using the available libprotobuf version (if that ever works). – Yushin Washio Aug 18 '17 at 20:13
0

This is the way it finally worked on the same Ubuntu 16.04 (xenial):

  1. add deb http://archive.ubuntu.com/ubuntu/ zesty main restricted universe multiverse to /etc/apt/sources.list and run sudo apt-get update (do not upgrade)
  2. sudo apt-get install uim-mozc uim-gtk2.0 uim-xim (uim-gtk3 had some runtime libprotobuf incompatibility issues and uim-xim seems necessary to actually change input method)
  3. start uim-xim and uim-toolbar-gtk or it should also run on reboot
  4. remove that zesty entry from /etc/apt/sources.list again

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.