2

I recently updated my laptop from Fedora 25 to 26. After the update, sometimes, usually after I close the lid, the trackpad stops working entirely. I can't move the pointer, click, or scroll.

Currently, I'm just restarting my computer from the terminal when this happens, which is very annoying. I've tried the following:

  • Boot the Fedora 25 kernel from Grub
  • Install the old mouse driver (xorg-x11-drv-synaptics-legacy)
  • Remove psmouse from the kernel and add it back (it says modprobe: FATAL: Module psmouse is builtin.)

None of these have worked. Anyone know how to fix this?

EDIT: Here is the output of dmesg | grep mouse after it has frozen:

[    0.819297] mousedev: PS/2 mouse device common for all mice
[    1.585896] psmouse serio1: synaptics: queried max coordinates: x [..5664], y [..4708]
[    1.612130] psmouse serio1: synaptics: queried min coordinates: x [1276..], y [1146..]
[    1.664277] psmouse serio1: synaptics: Touchpad model: 1, fw: 8.2, id: 0x1e2a1, caps: 0xf00623/0x840300/0x12e800/0x400000, board id: 3096, fw id: 2430125
[ 1455.599299] psmouse serio1: Failed to disable mouse on isa0060/serio1
[ 1457.549499] psmouse serio1: synaptics: queried max coordinates: x [..5664], y [..4708]
[ 1457.575672] psmouse serio1: synaptics: queried min coordinates: x [1276..], y [1146..]
[ 1933.961382] psmouse serio1: Failed to disable mouse on isa0060/serio1
[ 1935.980668] psmouse serio1: synaptics: Unable to query device.

Also, even if the trackpad doesn't work, a USB mouse still does.

  • 1
    I would open a bug on the Fedora bugzilla, but they would need more information: at least the make and model of your laptop, perhaps the module list and perhaps whether you are running Wayland or X. But they would tell you what additional information you'd need to submit. – NickD Jul 20 '17 at 13:17
  • I'm getting the same issue. Did you ever find a solution for this @FlyingPiMonster ? – Matt Healy Aug 16 '17 at 0:02
  • @MattHealy Actually, the problem seems to have disappeared for me. Is your system up to date? – FlyingPiMonster Aug 16 '17 at 15:45
0

Sounds like a conflicting IRQ or port is the issue, have you tried changing the IRQ? You can usually do this through your bios settings, which is the easiest way I'm aware of. May be able to be done through CLI but I don't know the command...

0

I had a similar problem happen to me after rebooting for the first time in a while (after many dnf updates). The trackpad was completely gone from "Mouse & Touchpad" in the Settings application. I ended up restoring the trackpad by entering the following section in /etc/X11/xorg.conf.d/00-keyboard.conf and rebooting

Section "InputClass"
    Identifier "touchpad catchall"
    MatchIsTouchpad "on"
    Driver "synaptics"
EndSection
0

I got exactly the same same during my upgrade to Fedora26. I just update my kernel, after the fresh install of Fedora 26, and it is working again, scrolling with both fingers is working as a charme, as it should...

With fresh install of Fedora 26, I got this kernel :

  • 4.14.5-200.fc26.x86_64

and after the update of the kernel :

  • 4.14.6-200.fc26.x86_64
  • actually, seems that I still got the problem ! When I suspend the laptop for a long time, I cannot used anymore the trackpad. So, if it is suspended just for a few minutes, it is working properly ! I known sounds stranges, but did try a few times ! – adamski Dec 24 '17 at 6:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.