2

Since a few weeks I'm having a problem with the IPv6 connectivity of my FreeBSD 11.0 server. There had been no software updates or configuration changes that I know of that could cause the problem.

The server only has IPv6 connectivity (incoming and outgoing) for a short time (approx. 40-80 minutes) after a reboot. Then it is gone and I don't know why.

It worked like a charm for months before.

This is my config:

/etc/rc.conf

#IPv4

ifconfig_vtnet0_name="em0"
ifconfig_em0="inet YY.YY.YY.YY netmask 255.255.252.0"
defaultrouter="188.TT.TT.TT"

# IPv6

ifconfig_em0_ipv6="inet6 accept_rtadv"
rtsold_enable="YES"
ifconfig_em0_alias0="inet6 2aXX:XXXX:XXXX:XXXX::1 prefixlen 64"
ipv6_defaultrouter="fe80::1%em0"

gateway_enable="YES"
ipv6_gateway_enable="YES"

ifconfig

em0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    options=6c07bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,TSO6,LRO,VLAN_HWTSO,LINKSTATE,RXCSUM_IPV6,TXCSUM_IPV6>
    ether ZZ:ZZ:ZZ:ZZ:ZZ:ZZ
    inet YY.YY.YY.YY netmask 0xfffffc00 broadcast 188.DD.DD.DD
    inet6 fe80::KKKK:KKKK:KKKK:1822%em0 prefixlen 64 scopeid 0x1
    inet6 2aXX:XXXX:XXXX:XXXX::1 prefixlen 64
    inet6 2aXX:XXXX:XXXX:XXXX::103 prefixlen 128
    nd6 options=23<PERFORMNUD,ACCEPT_RTADV,AUTO_LINKLOCAL>
    media: Ethernet 10Gbase-T <full-duplex>
    status: active
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
    options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
    inet6 ::1 prefixlen 128
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x2
    inet 127.0.0.1 netmask 0xff000000
    inet 10.0.0.1 netmask 0xffffffff
    inet 10.0.0.4 netmask 0xffffffff
    inet 10.0.0.3 netmask 0xffffffff
    nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
    groups: lo
pflog0: flags=141<UP,RUNNING,PROMISC> metric 0 mtu 33160
    groups: pflog

The routing tables stay the same after the fail:

netstat -rn

Routing tables

Internet:
Destination        Gateway            Flags     Netif Expire
default            188.TT.TT.TT        UGS         em0
10.0.0.1           link#2             UH          lo0
10.0.0.2           link#2             UH          lo0
10.0.0.3           link#2             UH          lo0
10.0.0.4           link#2             UH          lo0
10.0.0.10          link#2             UH          lo0
10.0.0.11          link#2             UH          lo0
10.0.0.12          link#2             UH          lo0
10.0.0.13          link#2             UH          lo0
127.0.0.1          link#2             UH          lo0
188.TT.TT.0/22     link#1             U           em0
YY.YY.YY.YY       link#1             UHS         lo0

Internet6:
Destination                       Gateway                       Flags     Netif Expire
::/96                             ::1                           UGRS        lo0
default                           fe80::1%em0                   UGS         em0
::1                               link#2                        UH          lo0
::ffff:0.0.0.0/96                 ::1                           UGRS        lo0
2aXX:XXXX:XXXX:XXXX::/64             link#1                        U           em0
2aXX:XXXX:XXXX:XXXX::1               link#1                        UHS         lo0
2aXX:XXXX:XXXX:XXXX::102             link#1                        UHS         lo0
2aXX:XXXX:XXXX:XXXX::103             link#1                        UHS         lo0
fe80::/10                         ::1                           UGRS        lo0
fe80::%em0/64                     link#1                        U           em0
fe80::KKKK:KKKK:KKKK:1822%em0     link#1                        UHS         lo0
fe80::%lo0/64                     link#2                        U           lo0
fe80::1%lo0                       link#2                        UHS         lo0
ff02::/16                         ::1                           UGRS        lo0

There is no cronjob besides a weekly check for updates.
What could be causing this?
Any logs I should check? Anything I might be missing?
Thanks!

  • You should add some more info about the network architecture and how you diagnose these IPv6 connectivity problems. There is also a good chance that there are problems somewhere else, since you said it worked and suddenly, without touching anything, it fails. – Martin Sugioarto Jul 19 '17 at 12:07
  • thanks for pointing it out. The server's services aren't available over IPv6 any more, also a trace route doesn't work. Also I can't pin6 and traceroute6 from the server to the outside after the failure. Only pinging the gateway still works. – basbebe Jul 19 '17 at 12:22
  • @basbebe Did you figure out why this happened? I'm having the same problem on one of my servers (Hetzner). – snøreven Oct 29 '17 at 15:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.