1

Has anybody used docker on Ubuntu and later found they cannot connect to the internet? I started using it for the first time yesterday and today I can't connect via wifi or ethernet!

I have spent the last day or so troubleshooting and have found that the drivers are now missing (at least that's what I think is causing the problem).

Apparently the kernel is supposed to take care of this in my current Linux version, so it's not just a matter of downloading new ones.

• ifconfig reveals no wifi or ethernet adapters.

• lspci shows that they are there.

• lshw tells me that they don't have their drivers.

I have tried downloading and installing several packages by transferring them by usb, but nothing seems to work for me.

I'm on Ubuntu 16.04.2 LTS.

enter image description here enter image description here

I really not sure what to do at this point.

  • I would check the kernel log... – marc Jul 18 '17 at 22:05
  • I had a check of the kernel log and it had 48 hours worth of logs (which covers the time from when I installed docker). Unfortunately, I don't really know what I'm checking for. I tried doing searches using key words like 'network', 'wireless' and 'AR9285', etc. but didn't see anything stand out as being useful. I uploaded it to uploadedit.com if someone who knows what to look for wants to take a look. Here's the link: kernel log Or if someone can tell me what I need to look for that would be great too. – CompSciGuyIT Jul 19 '17 at 0:56
0

After considerable digging around and being on the brink of resorting to a fresh install of the operating system. I discovered a post by @weronika who suggested that booting from another kernel might help.

Not being sure how to do this I did more digging and found a post on askubuntu.com by a user called @DaimyoKirby who explained how to change the grub file.

I made a copy of /etc/default/grub calling it /etc/default/grub.bak with the command

sudo cp /etc/default/grub /etc/default/grub.bak

and made the change suggested by @DaimyoKirby to /etc/default/grub by changing

GRUB_DEFAULT=0

to

GRUB_DEFAULT="Advanced options for Ubuntu>Ubuntu, with Linux 4.4.0-81-generic"

(I found my previous version of the kernel by looking in the /usr/src directory). After this I rebuilt grub with

sudo update-grub

On reboot I was back to my previous version of the kernel and once again had an internet connection. I'm not sure if it was necessary but considering there were pending updates I did a

sudo apt-get update
sudo apt-get upgrade

and a

sudo apt-get -f install

as was suggested.

After this, I thought I'd try going back to the newer kernel I was on originally, hoping everything would still work, and it did. I made a copy of the grub file again just to be safe calling it grub.prev.bak, swapped the other backup file with current grub file, and once again rebuilt grub.

sudo cp /etc/default/grub /etc/default/grub.prev.bak
sudo cp /etc/default/grub.bak /etc/default/grub
sudo update-grub

On reboot I was back with the latest kernel version I was using and still had internet. ifconfig revealed the once missing network interfaces.

I once again did a

sudo apt-get update
sudo apt-get upgrade

and after this I was golden. =D

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.