1

I have a bad keyboard on my laptop that I run Linux on. Function keys F1 and F7 and the Backspace key do not send keystrokes to the system. I have gotten used to pressing the left arrow, followed by DELETE in place of backspace, and I ignore F1 completely using the program menus to find options to make F1 unnecessary for me.

However, I'm having problems with F7. Alt-F7 should return me to the Xwindow environment after pressing Ctrl-Alt-F2 for a terminal window. It really bothers me that older linux systems used /etc/inittab to tell the system how many virtual terminals to start up and put the Xwindow after the last virtual terminal. With my jessie install I can't get the system to create a different number of virtual terminals.

I edited /etc/systemd/logind.conf uncommenting NAutoVTs=6 and ReserveVT=6, then changing the lines to read: NAutoVTs=7 ReserveVT=7

should have fixed the problem by moving the Xwindow to Alt-F8. After rebooting I discovered that this did not change anything. The Xwindow is still on VT7.

Next I tried editing /lib/systemd/system/getty.target.wants/getty-static.service. In the [Service] section I added getty@tty7.service to the end of the ExecStart= line. When I rebooted the system I discovered that I now have a virtual terminal on tty8, but the Xwindow is still being loaded on tty7. Is there any way I can get the Xwindow to move to tty8 without reinstalling the system and going back to the SysV init method?

I enjoy tampering with improvements on the system, but sometimes they puzzle me greatly and make me wish it was still the 1990's and X hadn't been invented yet.

Any help would be greatly appreciated!

Roger

1

For GDM, you can set the first free terminal device in the /etc/gdm/custom.conf file.

$ cat /etc/gdm/custom.conf
# GDM configuration storage
#
# See /usr/share/gdm/gdm.schemas for a list of available options.
[daemon]
...
# Reserving more VTs for test consoles (default is 7)
FirstVT = 8
...

After that, at least restart gdm, b, to be sure, just # reboot.

| improve this answer | |
  • Adding custom.conf to /etc/gdm3/ with the following statements, then rebooting: resulted in a text vt on F8 with X still on F7. [daemon]. FirstVT = 8 unfortunately my phone keyboard won't let me put CR after lines. – RdGreenlaw Aug 3 '17 at 2:20
0

I am not quite sure about whether you can choose the tty device, but a reconfiguration of the Xorg server may be helpful:

# dpkg-reconfigure xserver-xorg

If it doesn't help, take a look at the Xorg configuration files, findable at:

$ find / -name xorg.conf -print 2>/dev/null

and check for helpful settings, or at least post some interesting sections, if any.

| improve this answer | |
  • My system didn't seem to do anything with dpkg-reconfigure. Returned to the # with no messages. Find xorg.conf also doesn't display anything before returning to the # prompt. – RdGreenlaw Aug 2 '17 at 1:59
  • What display manager (xdm, gdm, kdm, lightdm, …) do you use? – xanoetux Aug 2 '17 at 5:57
  • I'm using gdm3. – RdGreenlaw Aug 2 '17 at 12:24
  • Okay, then try my new answer – xanoetux Aug 2 '17 at 21:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.