0

I am trying to enable the serial console on my SystemD VM so I can get in to it via the console, but when connecting it is not letting me select the user.

Reading through the serial console documentation it seems that I only need to add console=ttyS0 to the COMMAND_LINE_LINUX section of grub, and SystemD will automatically start listening for serial connections.

When connecting to the system via virsh console {system_id} it outputs:

$ sudo virsh console 1
Password:

With no user prompt.
I tried the user's password, and setting a root password but nothing seems to be working.
I tried setting up the serial terminal manually and setting autologin to the user:

systemctl enable serial-getty@ttyS0

Editing the agetty line to add --autologin user, but no effect.

I saw this question and confirmed that my kernel config should have CONFIG_FHANDLE=Y though I can't find the config file locally to verify, only in their repository.

Any ideas how I can get the serial console working?

2

This was another case of "I am an idiot".

I think I was mistaking my sudo password prompt for the VM user login...

Anyhow after rebuilding the machine the full steps to enable the serial console on Solus:

Client:

systemctl enable serial-getty@ttyS0
systemctl start serial-getty@ttyS0

Host:

sudo virsh console {system_id}

Making sure to type in your Host's sudo password, and you are done.

Interestingly I had to do it this way instead of just adding the Grub command line option, haven't figured out why yet.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.