0

I have installed the cinnamon desktop on arch.

I can't see any icons in my menu, but the .desktop files are there.

The icons are all specified to only show in "X-Cinnamon", but $XDG_CURRENT_DESKTOP is set to "GNOME".

Can anyone suggest why this is?

1

I have faced a similar situation while installing Arch Linux and Cinnamon.

In my case, if I logged in using Cinnamon, the Gnome desktop was shown. Nevertheless, if Cinnamon (Software Rendering) was used, everything worked as expected.

Cinnamon is the 3D accelerated version, thus, depends on the installed graphic card. Since it was not working, I had a problem with my graphics cards drivers.

My laptop, a Dell Inspiron 5547, has an Intel Integrated Graphics Processor (IDP) and also a Radeon R7 M265 Dedicated Graphics Processor (DGP). Once I installed the correct drivers and enabled hardware video acceleration everything worked like a charm.

  • Driver for Intel Integrated Graphics Controller

    # pacman -S xf86-video-intel mesa lib32-mesa
    
  • Driver for Radeon R7 M265

    # pacman -S xf86-video-ati mesa mesa-vdpau lib32-mesa lib32-mesa-vdpau
    
  • Enable hardware video acceleration through VA-API

    # pacman -S libva-intel-driver libva-vdpau-driver
    

References:

  • Thanks for the reply. I'll check this out and let you know. – Beakie Aug 12 '17 at 19:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.