0

I've installed Stretch(4.9.0-3) in a standard PC 2 weeks ago and all works perfectly fine.
But I recently downloaded a new DVD(3) same version to install this time in a usb-stick (3.0) without /swap.
Note: I have to say that it's much better install 1dvd then use internet because the installer looks bugged when ask to change to dvd#1, dvd#2 then dvd#1 again and never ask for dvd#3

So, I have a problem every time that I need to invoke the root from the standard user account: e.g. can't unlock account settings neither invoke root from the terminal and when open Software & updates nothing happens although I can check update from Settings->Details->CheckForUpdates.. there is nothing to update so I'm not sure I the standard user can update, probably not, but will ask for admin or what? capture

Although another StackExchange-user has a similar issue: he did mention to sudo and lot of answers are related to that.

NOTE: I can access through tty and edit, update, upgrade without problems. I think my problem could be given for the mount options that I chosen. picture

You will not see something like default at options because I explicitly change that. And I think that that-was-my-mistake:
At the /root installation stage there was a problem with the installation options. I'm not sure if it was -noexec- and I unchecked it, or if it was -nodiratime- and I unchecked that but it was marked anyway in some other configuration. What I'm plenty sure is that I uncheck one of them and the installation process continue as normal.


Well.. that's my problem. Beyond that my Cross-Hardware environment works perfectly well. I hope a long time but the truth is that I don't know enough about SSD configuration. OH!! by the way I'M NOT USING SWAP

What I will do: If you think there is no configuration problem with that mount options I will try from the tty in a to try to fix this without re install .
Please note that it makes no sense to reinstall if I'm doing wrong the mount options (that's would be my question)

1

Change the permissions on the file. Google is your friend, most of the problems you face, other people have also faced and solved. One google search and you might just find your solution.

chmod 4755 /usr/lib/policykit-1/polkit-agent-helper-1
  • The nosuid mount option specifies that the filesystem cannot contain set userid files. Preventing setuid binaries on a world-writable filesystem makes sense because there's a risk of root escalation or other awfulness there. In simple words, remove nosuid in /etc/fstab from all the partition's. Reboot, and then try Login.

Should be something like this:

UUID=a34cdfff-2388.. / ext4 noatime,nodiratime,errors=remount-ro 0 1
  • doesn't work :\ – Federico Gallo Jul 15 '17 at 23:28
  • -rwsr-sr-x 1 root root 14856 Jul 15 20:26 /usr/lib/policykit-1/polkit-agent-helper-1 – Federico Gallo Jul 15 '17 at 23:31
  • I think you're right but I think I'm doing wrong. I would try to change access to allow users. – Federico Gallo Jul 15 '17 at 23:35
  • -rwsr-xr-x 1 root root 14856 May 24 15:51 polkit-agent-helper-1 This is my polkit file. This is how it should be. I have edited the answer, now it should work. – Hunter.S.Thompson Jul 15 '17 at 23:40
  • I don't understand. chmod g+x doesn't change the group permissions but the time when modified was changed. Give me a minute – Federico Gallo Jul 15 '17 at 23:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.