2

I've been using this resource as a guideline to help with the dual boot process using a 2TB HDD:

I've installed windows first.

I've taken pictures of all the steps I've taken. However once I install Debian and reboot, it boots straight to Windows and appears to not be there in the windows boot loader? BTW apologies on the picture quality, this is posted from my phone.

*edit - I tried ubuntu instead of debian, and it says it can't detect any other operating systems on the HDD, even though the windows partition is there.

  • Try boot from SATA: ST2000... device. It is shown in your boot options. May be it will work :) You have installed Debian in the legacy BIOS mode, with MBR usage. – MiniMax Jul 15 '17 at 21:55
  • And reply, work it or not. Then I will can give more elaborate answer. – MiniMax Jul 15 '17 at 22:03
  • @miniMax, nope, doesn't work. Still boots straight to windows. – digitalXmage Jul 16 '17 at 9:10
  • I've just attempted it again. And it takes me to a black screen with the text: "Error: no such partition , Entering into rescure mode..." and gives me a "grub rescue>" prompt. – digitalXmage Jul 16 '17 at 9:23
  • 1
    Seems what is confusing you is the difference between MBR booting and UEFI booting. Mixing the two does not work and results in the behavior you are describing. You need to install Linux in UEFI mode. Then you should get the correct behavior. – ojs Jul 16 '17 at 10:57
1

Problem description:

You install Debian in the BIOS compatibility mode (Legacy BIOS), but Windows already installed in the new UEFI mode. It is cause grub doesn't see Windows bootloader and you can't choose Debian in the Boot menu. It can be booted, but only directly from hard drive (SATA: ST2000...) To fix this problem is needed reinstall Debian in the UEFI mode too.

From Debian wiki

On the PC architectures (amd64 and i386), UEFI-based firmware is a relatively new replacement for the ancient BIOS (Basic Input/Output System) that has existed ever since the PC was first developed in the 1980s. The old BIOS systems have strict limitations due to their ancient design, running in 16-bit mode with access to only 1MB of memory, and limited access to other resources like disks. UEFI firmware is normally fully native and so should be able to access all the system memory and all the devices.

For the sake of backwards compatibility, most current PCs using UEFI also include a Compatibility Support Module (CSM), extra support code that will continue to boot in the old BIOS style. Over time, this support will most likely be phased out. Some systems were already being sold UEFI-only (i.e. with no CSM) in 2014.

Solution:

For installing Debian in the UEFI mode, it is needed:

First variant

  • Insert your media for installing (USB, DVD)
  • Enter to the boot menu while PC starting (holding F8 in my case - Asus motherboard)
  • In my computer, I have two item for this media in the boot menu - one for Legacy BIOS booting and other for UEFI booting. Select the UEFI item.

enter image description here

Second variant (I found example's photos in the internet)

Disable Compatibility Support Module (CSM) in the UEFI settings:

enter image description here

Or change Boot mode to the UEFI, like this:

enter image description here

Then the Debian installer splash screen will say it's the UEFI installer, and will look like this:

enter image description here

Useful information:

  • Hi, thanks for the information. However when i click the UEFI version of my usb, instead of "general" version option. It then proceedes takes me to this screen. imgur.com/a/l6EfL , sorry for the inconvenience. – digitalXmage Jul 16 '17 at 16:29
  • @digitalXmage It is not booting in to the Debian at all? You click UEFI USB and get this screen (error: no such partition)? – MiniMax Jul 16 '17 at 17:22
  • yes it goes straight to that screen. I'm just not sure why this is occuring honestly. – digitalXmage Jul 16 '17 at 17:36
  • @digitalXmage Can you try Ubuntu USB the same way? Just now, tested it with Lubuntu, got GRUB menu with items "Try without installation", "Install Lubuntu", etc. – MiniMax Jul 16 '17 at 17:54
  • same happens with a ubuntu usb instead. I honestly not sure what to do now to get this to work. – digitalXmage Jul 16 '17 at 18:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.