2

My Macbook Pro's keyboard is malfunctioning and both its shift keys are pressing erratically. Other than that, it is fine.

In Macos 10.11, I solved that problem by using karabiner.

In Linux, Xmodmap didn't worK. Is there some command on setxkbmap that would work?

  • I edited the file /etc/default/keyboard adding the line XKBOPTIONS="caps:swapescape" to swap my caps lock and my escape key for using Vim. I think you can disable keys as well by using this file. These changes are system wide for all users. I'd add an answer if I had time to look into it fully for you. Also, I'm on Debian. askubuntu.com/questions/342066/… I also needed to install console-common and console-data for it to work (in Debian). – jbrock Jul 17 '17 at 15:57
  • I think changes will take effect in /etc/default/keyboard by rebooting without having to run sudo dpkg-reconfigure keyboard-configuration. – jbrock Jul 17 '17 at 16:47
0

There is a handy program called KeyRemap4MacBook that will let you do this.

  • Hello! So, I used it (which, by the way, has been renamed to karabiner), but I am using linux right now, and still haven't figured out a way to disable shift keys in ubuntu – Tiago Fassoni Jul 16 '17 at 12:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.