1

I have a UEFI dualboot system with Windows 10 and Ubuntu Mate. The Ubuntu Mate installation have setup Grub for choosing the OS. Now I want to change the default Grub theme.

Here the steps I have done:

1. Get theme archive: wget https://github.com/shvchk/poly-light/archive/master.zip
2. Unpack theme: unzip master.zip
3. Remove theme archive: rm master.zip
4. Create GRUB themes directory: sudo mkdir -p /boot/grub/themes
5. Move theme to GRUB themes directory: sudo mv poly-light-master /boot/grub/themes/poly-light
6. Set GRUB_THEME=/boot/grub/themes/poly-light/theme.txt in GRUB config: sudo nano /etc/default/grub
7. Update GRUB: sudo update-grub

But I see the default theme on startup installed by Ubuntu?! What I can do to change the theme correctly?

My GRUB config (/etc/default/grub/):

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT="saved"
#GRUB_HIDDEN_TIMEOUT="0"
GRUB_HIDDEN_TIMEOUT_QUIET="true"
GRUB_TIMEOUT="10"
GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash intel_idle.max_cstate=1"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL="console"

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE="640x480"

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID="true"

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

GRUB_SAVEDEFAULT="true"
GRUB_THEME="/boot/grub/themes/poly-light/theme.txt"

export GRUB_COLOR_NORMAL="light-gray/black"
export GRUB_COLOR_HIGHLIGHT="magenta/black"

Thanks

  • Could you show your GRUB config (/etc/default/grub)? – Shevchuk Oct 13 '17 at 18:28
  • I have added the content to my question. – fteinz Oct 13 '17 at 23:22
  • Those export ... lines should probably be without export part, but other than this everything seems fine, and even as is this should work (just tested your exact config in a VM). Are you sure theme is actually unpacked in /boot/grub/themes/poly-light/? You should see these files in /boot/grub/themes/poly-light/ directory: github.com/shvchk/poly-light – Shevchuk Oct 15 '17 at 6:00
  • It work now. I have comment out the export lines but that was not the problem. I have make a sudo apt-get remove grub2-themes-ubuntu-mate and a update-grub and now it work. I dont know why... Thanks – fteinz Oct 16 '17 at 23:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.