0

I want to install the barman pkg - (this backup server)
during yum , yum failed on dependencies

I not understand well what yum is really neded from the errors down my python version on my linux is 2.7.5 I not sure according to yum error , but seems that yum need the old python version - 2.7 - so need to perform python downgrade ?

please advice what is needed to resolve this dependencies and what I need to do in this case?

yum install barman . .

       Error: Package: python-argh-0.23.2-1.el6.noarch (epel)
       Requires: python(abi) = 2.6
       Installed: python-2.7.5-34.el7.x86_64 (@anaconda/7.2)
           python(abi) = 2.7
           python(abi) = 2.7
       Available: python34-3.4.5-2.el6.i686 (epel)
           python(abi) = 3.4
       Error: Package: python-argcomplete-0.8.8-1.el6.noarch (epel)
       Requires: python(abi) = 2.6
       Installed: python-2.7.5-34.el7.x86_64 (@anaconda/7.2)
           python(abi) = 2.7
           python(abi) = 2.7
       Available: python34-3.4.5-2.el6.i686 (epel)
           python(abi) = 3.4
0

It appears you are running CentOS/Redhat 7. The errors seem to be occurring due to the inclusion of the Epel repository for CentOS/Redhat version 6.

EDIT:

According to this wiki, download and install epel-release-latest-7.noarch.rpm.

sudo rpm -ivh epel-release-latest-7.noarch.rpm

You can verify these packages and their keys from the Fedora project's keys page: https://fedoraproject.org/keys.

Be sure to remove (or at a minimum, disable) the epel el6 repository.

  • so in this case how to download epel for version 7 ( redhat ) – yael Jul 13 '17 at 21:18
0

If I understand you correctly there is confusion about dependencies of the barman package.

You can find out the dependencies of a package that is not yet installed by using the repoquery tool.

repoquery --requires <package>

Since you might already have some of the dependencies satisfied, list only the ones that remain outstanding using:

repoquery --requires --resolve <package>

If you run into a similar situation on an Ubuntu based system, the apt tool can provide the same information via:

apt depends <package>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.