0

I made some Live USBs using both Tuxboot and USB Image Writer but I can't boot any of them. I've tried most of them on other computers and they all work.

When I press ESC while booting I'm taken to the grub menu, but only my main system appears there (Linux Mint 18.1) and an option to go to the BIOS config.

If I go to the BIOS and change the boot order so that EFI Flash goes first the system reboots but boots normally on my main OS. The next time I access the BIOS the order is returned to the original settings.

A few notes:

  • I have a samsung NP900 laptop with SSD
  • I'm using the linux kernel v4.10 on a Mint 18.1
  • I have secure boot set as custom, and I haven't tried without it because I'm worried by system won't boot

The output of efibootmgr is

BootCurrent: 0006
Timeout: 0 seconds
BootOrder: 0006,0005,0004,0002,0000
Boot0000* Windows Boot Manager
Boot0002* Windows Boot Manager
Boot0004* UEFI: Generic Flash Disk 5.00
Boot0005* UEFI: Generic Flash Disk 5.00
Boot0006* ubuntu

Those two Windows entries are there, but I don't have any Windows installed. I changed the boot order with sudo efibootmgr -o 0004,0005,0006,0000,0002 and rebooted but again, system booted into main OS. And after I checked boot order again it was set as 0006,0005,0004,0002,0000, which is not what it was when I restarted it.

0

When I use the standard USB boot image writer, my USB drive also won't boot.

I'm using either dd if=/path/to/livelinux.iso of=/dev/< your USB stick> or my Windows VM with the tool "Rufus".

Also make sure that your live Linux supports UEFI.

  • I haven't tried to use dd to make the live USB, but I don't believe the problem is that because (i) the boot order doesn't stick and (ii) the live USBs that I've been trying work on other computers. I'll add that info to the question – TomCho Jul 14 '17 at 20:28
  • Is there an option to enable boot of non-EFI systems? (often called "legacy boot" or "CSM" (compatibility support module)) You should also try turning off secure boot as it won't let systems without a signed bootloader start. Disabling it won't affect the ability to boot your Mint as it only checks the bootloader signature. Even if your Mint won't boot after disabling it (I don't think so), you could just re-enable it.. – RootTutGut Jul 14 '17 at 22:02
  • Disabling secure boot didn't make any difference. I haven't tried the legacy version. Won't it prevent my OS from booting, since it was installed in EFI mode? – TomCho Jul 15 '17 at 18:10
  • Depends on your BIOS/UEFI. On my Laptop and on my PC I've got the Option "UEFI with CSM". Using this I can boot both kinds. But as I said to secure boot: if your system won't start afterwards, just change the setting back. – RootTutGut Jul 15 '17 at 22:40
  • Sorry for the delay. Changed by boot to CSM and still I got the same results. Used CSM with UEFI and also same thing. Ideas? – TomCho Aug 9 '17 at 6:59
0

Ended up solving it by setting everything back to the defaults in the BIOS and then instead of changing the boot order in the BIOS, I pressed F10 during boot to manually choose which partition to boot from.

Apparently this is just a workaround, and it should be able to boot with the settings I used in my initial attempt, so I contacted Samsung and they say that the laptop needs to be re-imaged.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.