After a fresh installation of Debian Jessie, I go to settings -> sound and I see no output devices available on the server. But when I look for audio devices I am able to find two audio controllers.

lspci | grep -i audio
00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)

speaker-test 1.0.28

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 192 to 2097152
Period size range from 64 to 699051
Using max buffer size 2097152
Periods = 4
was set period_size = 524288
was set buffer_size = 2097152
 0 - Front Left
Time per period = 10.930638
 0 - Front Left
Time per period = 10.939728
 0 - Front Left
Time per period = 10.939957
 0 - Front Left
Time per period = 10.940891
 0 - Front Left
Time per period = 10.941652
 0 - Front Left
Time per period = 10.939757
 0 - Front Left
Time per period = 10.939337
 0 - Front Left

I have restarted pulseaudio many times like this:

pulseaudio --start

That does not seem to work either.

  • If it's a server install, why does it need audio? If you need audio, why not a desktop install? – tripleee Jul 13 '17 at 10:01
  • Does this return anything: lsmod | grep snd_hda_intel ? Have you tried the ubuntu howto ? help.ubuntu.com/community/HdaIntelSoundHowto – thecarpy Jul 13 '17 at 10:13
  • Try running alsactl init. This attempts to do a configuration. Also try running pavucontrol, it's a useful debugging tool. Also, avoid running PulseAudio as root. Bad things will happen. – Faheem Mitha Jul 13 '17 at 15:13

You could try this (from https://help.ubuntu.com/community/HdaIntelSoundHowto):

Manually Specify Module Parameters

First you must find which model of sound card you use, so run this command:

cat /proc/asound/card0/codec* | grep Codec

It will return model of your sound card(s), for example: "Codec: Realtek ALC260", so your sound card is ALC260.

You should open a file in ALSA documentation. This file is here:


or if that file does not exist, try:


or check: HD-Audio-Models

(If you compiled your own kernel or ALSA modules, the documentation for your version can probably be found in the source package you used)

Search for your model, and take a look at its types, for example I found the following lines for ALC260:

hp              HP machines 
hp-3013         HP machines (3013-variant)
fujitsu         Fujitsu S7020 
acer            Acer TravelMate 
basic           fixed pin assignment (old default model) 
auto            auto-config reading BIOS (default)

Read all of them and try to find the one which is more similar to your sound card, for example if you have a laptop, you can choose "acer".

Open /etc/modprobe.d/alsa-base with the following command:

 sudo nano /etc/modprobe.d/alsa-base

In Ubunty Jaunty and more recent, the file ends with .conf :

sudo nano /etc/modprobe.d/alsa-base.conf

Then paste the following line at the end of the file (change MODEL with the type of sound card's model, in our example it should be "acer" (without quotation marks)):

options snd-hda-intel model=MODEL

sudo alsa force-reload

Suitable options for many popular laptop models can be found in this forum thread


I'd like to add an example to clarify: my mic did not work under Ubuntu (whereas playback did and the mic itself worked under Vista). I actually found out that my Realtek audio codec was ALC269 by typing

cat /proc/asound/card0/pcm0c/info

(and/or by looking into Vista Control Panel (Sound)). Looking at the ALSA-Configuration.txt this corresponds to model basic, so I added

 options snd-hda-intel model=basic

at the end of /etc/modprobe.d/alsa-base and rebooted.

Playing with probe_mask

Another possible option is the probe_mask parameter, which has been known to fix sound issues characterized by the occurrence of "azx_get_response timeout, switching to single_cmd mode" messages reported with 'dmesg'. Try either "probe_mask=1" or "probe_mask=8" by adding a line like:

options snd-hda-intel probe_mask=1

For detailed information about this problem, see More Notes on HD-Audio Driver by Takashi Iwai, section 2.2. "Codec-Probing Problem".


This error was caused due to previous Ubuntu 12.04 configuration files left in the old user's home directory, creating a new user and moving all except the . files solved the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.