0

I'm getting this error while upgrading to Fedora 26 from 25

Detailed errors from the package manager follow:

Error running transaction: file /usr/bin/pytest from install of python2-pytest-3.1.1-1.fc26.noarch conflicts with file from python-logilab-common-0.63.2-6.fc25.noarch

Any solution?

  • 2
    try removing the python-logilab-common-0.63.2-6.fc25.noarch package before the upgrade? – DopeGhoti Jul 12 '17 at 18:29
1

First, it's worth checking whether the package is obsolete; in this case, it is.

Assuming you're following the instructions outlined here, two things you can try:

First, at step 3 from the article, append "--allowerasing", to allow the upgrade process to remove obsolete packages. I.e., instead of:

# dnf system-upgrade download --releasever=26

use:

# dnf system-upgrade download --releasever=26 --allowerasing

If that doesn't work, than second, try @DopeGhoti's solution:

# dnf remove python-logilab-common

then repeat the previous command.

  • 2
    BTW, the upgrade document indicates using the --allowerasing already. – mdpc Jul 12 '17 at 23:51
  • True, and that's where I was drawing that from. Sorry I implied it was my addition. – bgvaughan Jul 13 '17 at 15:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.