0

Yesterday I downloaded Android Studio for my Debian Testing system. I wanted to run a HelloWorld application (just a blank activity) but weren't able to run it. With adb I can install it without having any problems.

However, if I try to do it with Android Studio, it gets stuck on 'Installing APKs'. The same happens when I try to start it in an emulator (gets stuck on 'Waiting for target device to come online').

My device is a Samsung Galaxy S3 with LineageOS (Android 7.1.2) and root permissions. Android Studio recognizes my phone properly.

What I've already done:

  • installed with openjdk
  • installed with oracle jdk
  • set android_home
  • installed all the SDK-platforms since Android 4.3 and Android Emulator from SDK tool
  • installed everything from SDK tool
  • enabled USB-debugging
  • tried with MTP and PTP
  • tried another emulated phone
  • installed lib32stdc++6
  • restarted my computer
  • created new blank activity
  • reinstalled everything: JDK, Android SDK and Android Studio
  • and probably much more

I do not get any error.

Today I managed to have the emulator start by setting graphics to software but it just shows a black screen and doesn't power on.

I tried to do it until now and couldn't find a solution. I have never experienced anything close to this on other systems.

I really would like to get it running on Debian because I do not want to install Windows for this. I remember that I was able to run it on LMDE2 some time ago. So why doesn't it work on Debian Testing now? Did I forget something?

Thank you in advance.

EDIT: I am now able to use my phone to run the android application by using USB 2.0 instead of USB 3.0! Is that a normal behavior since it works with native adb? I mean, if I buy a new PC after some years which has got only USB 3.0 ports, will I not be able to use phone debugging with Android Studio or is this just an issue? It is still known since 2014 (https://stackoverflow.com/a/9548311/8292104).

However, I still cannot get the app running on an ADV. I changed graphics to software, now it shows the phone but the screen remains black and the phone won't start. What can I do to fix it?

1

I have the exact same setup as you with debian testing and installed android studio 2.3.3. It took me a while to find out that you have to set it to software graphics for the emulator phone to appear.

I still have the issue with the hello world app not appearing on the emulator and the emulator appearing as blank. I have the API set at 26. API 26 is android O which is not released yet.

As I workaround i have tried API 23.

If I try the hello world example with API 23 which is android 6 marshmallow I get the hello world example to work. It can work by click run button from the studio and clicking a device that is set to API 23. You must configure the device before launching the programme.

When you launch the emulator the word android will appear on the screen first. This means it is working.

As a test with out the hello world example setup a phone like Nexus 6P and set the API version to 23. Then run this command to see if will start and show you the android word. ~/Android/Sdk/emulator/emulator -avd Nexus_6P_API_23 -use-system-libs

Edit: I changed to using the nvidia priority drivers and now i can use the emulator with API 26 on any phone. I was using the nouveau drivers and that was producing a double free which killed the emulator display. Try with the command line example above to see what errors you get when starting the emulator.

  • Yes, I can just see the emulator if I choose particular settings (I've also changed it to software graphics) but it has a black screen for me and won't start at all. Meanwhile I develop without an emulator but later I'll have to look over it again when I've finished the app I'm working on currently. – tavkomann Aug 4 '17 at 14:40
  • do not have enough points to add a direct comment. – Martin Naughton Aug 4 '17 at 15:26
  • @tavkomann do have a nvidia graphics card? are you using nouveau on debian? – Martin Naughton Aug 4 '17 at 16:00
  • Found the solution to the issue and edited my post. – Martin Naughton Aug 4 '17 at 18:22
  • @MartinNaughton I've already tried other APIs but it seems that 23 is the only one working. Thank you! And yes, I use Nouveau. – tavkomann Aug 6 '17 at 19:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.