-2

I'm trying to install Debian 9.0.0 (amd64) on some old computers. The computers are of the same model, and should be identical.

With the first one, installation was successful. There was, however, an issue with configuring the network, namely that auto configuration failed. I did, however, manage to configure the network manually. This is probably irrelevant to the other problems discussed below.

With the other computers, I ran into problems at an earlier stage. I initially used a DVD for the installation, as I had successfully done with the first computer. I got to the Debian installation menu. Regardless of whether I picked graphical or non-graphical installation, I got a "black screen with blinking cursor", and the computer eventually rebooted.

Note that I used the same DVD-drive, which had previously worked, and moved it between the computers. I also burned a new DVD, but it made no difference.

I tried setting all_generic_ide=1, since I was using an IDE drive. I now got error messages (after passing the installation menu) along the lines of exception Emask ... frozen and blk_update_request: I/O error, dev sr0.

I also tried installing from USB. First, I attempted to make a bootable USB simply by copying, using cp, the iso image to (an empty) USB stick. This produced the error Operating System Not Found. I also tried making a bootable USB by using the UNetbootin tool. This time, I got the error message Remove disks or other media. In neither case did I make it to the Debian installation menu.

Any help would be greatly appreciated!

EDIT I have now managed to install Debian on the remaining computers using a bootable USB. Many of the issues I experienced might be due to the dated hardware. I can see myself that my question is not very good - my apologies. Feel free to delete it.

  • "Should be" is such a lovely, lovely term... – Shadur Jul 12 '17 at 8:53
2

Making a bootable usb is absurdly easy.

How/Why does cat write a bootable ISO to a device

Assuming here that the usb is /dev/sdb

cat file.iso > /dev/sdb

I don't understand why you don't just clone the first disk you installed to then tweak the few things you need to change, like /etc/hostname, maybe nic ids, there's not a lot that requires customization.

Wnen I used to do a lot of distro support, one of the most frequent problems we encountered was people burning the install cd/dvd using too high a speed, which led to corruptions in the optical disk data, which led to strange failures. Also, of course, low quality optical disks cause issues as well. Audio and Video optical disks support a significant amount of data corruption for playback, which is why they still work when scratched etc, but that type of corruption makes binary data like you'd find on an install iso totally fail, or fail in odd unpredictable ways.

USB is obviously the preferred method because you don't have those types of issues in general, plus you don't have to keep making disks that you are going to throw away, but not all machines boot from usb.

[added in response to comment] First, when you 'copy' data, that's not the same as writing it with cat to the usb device. cp vs cat > that is, though cat or dd do copy the data directly without any changes to the usb device, while cp would copy the data to a partition made on the device, which would not be bootable of course. So that wasn't clear. If you used cat as I indicated, then you have another issue, possibly a bad usb drive, possibly the machine does not support boot from usb, possibly you didn't trigger the boot menu option to boot from the usb device.

However, because cat is so easy and simple to remember, there's no reason to complicate the matter further. Note that the iso contains the bootloader. The link I posted has some good explanations of this process so I won't repeat them here. But if you cat the iso to the usb correctly, and if it does not boot, you have another, unrelated issue. For example, several of my systems don't support booting from usb, they are older.

Second, no, I wouldn't clone a disk from a running os, from itself, that is, that's because the running os has a lot of stuff happening live which I don't want to copy to a clone, logs, all kinds of stuff, you clone it once you've gotten the install on it exactly the way you want all the machines to be. Since you have > 1 machines, that's easy, just boot from a live system maintenance cd, and do the cloning from there, that way you know that the cloned disk is going to be the same as the resulting disk. ultimate boot cd has a lot of options like that, parted magic for example give you a good working environment.

There's an alternate way to do it, which is to clone just the partition the root drive is on. That's what I would lean towards doing because it avoids potential issues with cloning different sized disks, but then you have to manually install grub onto the system, a true disk clone clones the boot sector as well. I'm not sure about clonezilla for example, ideally you can clone just the partition and boot sector, some cloning tools support that option, others don't.

Note that you can also simply connect the two disks (to be cloned, and clone) to a different running system if you have external usb drive devices, then clone them that way, that's easy.

[update 2, in response] Note that if you get a specific error message, just google it, and you'll find the answer, which is probably maybe this: https://askubuntu.com/questions/256739/ubuntu-12-10-wont-boot-from-usb-isolinux-bin-missing-or-corrupt

I came across this problem(isolinux.bin missing or corrupt) recently. The flash disk is made by dd, the iso file is of 12.04.3 64 bit. I fix this by change BIOS setting: change

USB Flash Drive Emulation Type

from 'auto' to 'hard drive'. Hope this helps.

It's also possible your downloaded iso is corrupted, which you can verify by checking it's md5 sum.

https://bbs.archlinux.org/viewtopic.php?id=107241

note that you don't need to pay attention to the dd stuff in that thread, cat is easier. I assume you did the cat as root?

  • Thanks! As I said, I did try to create a bootable USB my copying the iso file to the USB stick. When trying to boot, I got the Operating System Not Found error. That's why I also tried UNetbootin. Okay, maybe cloning could be a viable option. Any suggestions on how I would do this (sorry if stupid question)? Would I mount the hard drive in the working computer and simply copy the contents of the hard drive? – Étienne Bézout Jul 11 '17 at 20:34
  • Thanks! Yes, I did use cp. I'll try using cat also before I attempt cloning. Just to clarify, you mean that I should mount the hdd in the working computer, boot from a live cd and do the cloning from there, right? – Étienne Bézout Jul 11 '17 at 20:49
  • cp of course won't work, all that does is cp the iso file into the usb partition, as a file, inert. Mounting is a technical term, that means, mounting the drive partition within an OS of some type, you install the two disks, the one you are going to clone to and the one you are cloning, then you clone them using a clone tool, like clonezilla – Lizardx Jul 11 '17 at 20:51
  • Hmm, I tried making a live USB using cat. Now I got isolinux.bin missing or corrupt. – Étienne Bézout Jul 11 '17 at 21:06
  • 1
    I posted one possible answer, but you need to use google a bit more, whenever you get a specific error message, google it, and you will find the answer. – Lizardx Jul 11 '17 at 21:12

Not the answer you're looking for? Browse other questions tagged or ask your own question.