1

I am using Plesk on an Ubuntu 14.04 server and experiencing some strange problems:

I checked mount:

/dev/vzfs on / type reiserfs (rw,usrquota,grpquota)

Then stat /dev/vzfs:

stat: cannot stat ‘/dev/vzfs’: No such file or directory

Then df:

Filesystem     1K-blocks      Used Available Use% Mounted on
/dev/vzfs      209715200 177877760  31837440  85% /
none             2097152         4   2097148   1% /dev
none                   4         0         4   0% /sys/fs/cgroup
none              419432       104    419328   1% /run
none                5120         0      5120   0% /run/lock
none             2097152         4   2097148   1% /run/shm
none              102400         0    102400   0% /run/user

And df -i:

Filesystem                   Inodes                IUsed      IFree IUse% Mounted on
/dev/vzfs      18446744070447236696 18446744069415584328 1031652368  100% /
none                         524288                   61     524227    1% /dev
none                         524288                    1     524287    1% /sys/fs/cgroup
none                         524288                  118     524170    1% /run
none                         524288                   12     524276    1% /run/lock
none                         524288                    2     524286    1% /run/shm
none                         524288                    1     524287    1% /run/user

The inode counts are terribly close to the 64 bit arithmetic limit, so I suspect an integer overflow to cause the problems.

Other users cannot write to files thanks to quota limitations, even though I never set any specific quotas.

I don't know how to debug and/or solve this problem, can someone help me with this?


Update: I disabled quotas in the VPS settings of my provider, and mount now indicates that the type of the filesystem changed:

/dev/vzfs on / type vzfs (rw,relatime)

I also created the file in /dev using mknod, stat /dev/vzfs now says

  File: ‘/dev/vzfs’
  Size: 0               Blocks: 0          IO Block: 4096   block special file
Device: 9eh/158d        Inode: 2347445354  Links: 1     Device type: 0,ba
Access: (0644/brw-r--r--)  Uid: (    0/    root)   Gid: (    0/    root)
Access: 2017-07-11 16:59:42.471740071 +0200
Modify: 2017-07-11 16:59:42.471740071 +0200
Change: 2017-07-11 16:59:42.471740071 +0200
 Birth: -

df -i still shows this:

Filesystem                   Inodes                IUsed      IFree IUse% Mounted on
/dev/vzfs      18446744070447246304 18446744069415584345 1031661959  100% /
none                         524288                   62     524226    1% /dev
none                         524288                    1     524287    1% /sys/fs/cgroup
none                         524288                  120     524168    1% /run
none                         524288                   12     524276    1% /run/lock
none                         524288                    2     524286    1% /run/shm
none                         524288                    1     524287    1% /run/user

And there are still error messages:

-bash: cannot create temp file for here-document: Disk quota exceeded

I originally posted this question at ask ubuntu but it was suggested to post it here.


Update: I restored a backup from a few days ago and the server seems to be running without problems. inode counts are back to normal, but I am pretty close to the inode limit set by my hosting provider, so that might be the problem.

  • Welcome to U&L! To avoid your question here being closed for being cross-posted, please close your other one – Jeff Schaller Jul 11 '17 at 15:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.