2

I have installed kali-linux rolling 2016.1 recently and the output of uname -a is

Linux kali 4.3.0-kali1-amd64 #1 SMP Debian 4.3.3-5kali4 (2016-01-13) x86_64 GNU/Linux

After installation I updated my sources.list file according to latest repositories available

deb http://http.kali.org/kali kali-rolling main contrib non-free
# For source package access, uncomment the following line
# deb-src http://http.kali.org/kali kali-rolling main contrib non-free

After running apt-get update command I am unable to update packages list, its simply not working by displaying output

root@kali:~# apt-get update
Ign:1 http://http.kali.org/kali kali-rolling InRelease
Ign:2 http://http.kali.org/kali kali-rolling Release
Ign:3 http://http.kali.org/kali kali-rolling/main amd64 Packages
Ign:4 http://http.kali.org/kali kali-rolling/main all Packages
Ign:5 http://http.kali.org/kali kali-rolling/main Translation-en_US
Ign:6 http://http.kali.org/kali kali-rolling/main Translation-en
Ign:7 http://http.kali.org/kali kali-rolling/contrib amd64 Packages
Ign:8 http://http.kali.org/kali kali-rolling/contrib all Packages
Ign:9 http://http.kali.org/kali kali-rolling/contrib Translation-en_US
Ign:10 http://http.kali.org/kali kali-rolling/contrib Translation-en
Ign:11 http://http.kali.org/kali kali-rolling/non-free amd64 Packages
Ign:12 http://http.kali.org/kali kali-rolling/non-free all Packages
Ign:13 http://http.kali.org/kali kali-rolling/non-free Translation-en_US
Ign:14 http://http.kali.org/kali kali-rolling/non-free Translation-en
Ign:3 http://http.kali.org/kali kali-rolling/main amd64 Packages
Ign:4 http://http.kali.org/kali kali-rolling/main all Packages
Ign:5 http://http.kali.org/kali kali-rolling/main Translation-en_US
Ign:6 http://http.kali.org/kali kali-rolling/main Translation-en
Ign:7 http://http.kali.org/kali kali-rolling/contrib amd64 Packages
Ign:8 http://http.kali.org/kali kali-rolling/contrib all Packages
Ign:9 http://http.kali.org/kali kali-rolling/contrib Translation-en_US
Ign:10 http://http.kali.org/kali kali-rolling/contrib Translation-en
Ign:11 http://http.kali.org/kali kali-rolling/non-free amd64 Packages
Ign:12 http://http.kali.org/kali kali-rolling/non-free all Packages
Ign:13 http://http.kali.org/kali kali-rolling/non-free Translation-en_US
Ign:14 http://http.kali.org/kali kali-rolling/non-free Translation-en
Ign:3 http://http.kali.org/kali kali-rolling/main amd64 Packages
Ign:4 http://http.kali.org/kali kali-rolling/main all Packages
Ign:5 http://http.kali.org/kali kali-rolling/main Translation-en_US
Ign:6 http://http.kali.org/kali kali-rolling/main Translation-en
Ign:7 http://http.kali.org/kali kali-rolling/contrib amd64 Packages
Ign:8 http://http.kali.org/kali kali-rolling/contrib all Packages
Ign:9 http://http.kali.org/kali kali-rolling/contrib Translation-en_US
Ign:10 http://http.kali.org/kali kali-rolling/contrib Translation-en
Ign:11 http://http.kali.org/kali kali-rolling/non-free amd64 Packages
Ign:12 http://http.kali.org/kali kali-rolling/non-free all Packages
Ign:13 http://http.kali.org/kali kali-rolling/non-free Translation-en_US
Ign:14 http://http.kali.org/kali kali-rolling/non-free Translation-en
Ign:3 http://http.kali.org/kali kali-rolling/main amd64 Packages
Ign:4 http://http.kali.org/kali kali-rolling/main all Packages
Ign:5 http://http.kali.org/kali kali-rolling/main Translation-en_US
Ign:6 http://http.kali.org/kali kali-rolling/main Translation-en
Ign:7 http://http.kali.org/kali kali-rolling/contrib amd64 Packages
Ign:8 http://http.kali.org/kali kali-rolling/contrib all Packages
Ign:9 http://http.kali.org/kali kali-rolling/contrib Translation-en_US
Ign:10 http://http.kali.org/kali kali-rolling/contrib Translation-en
Ign:11 http://http.kali.org/kali kali-rolling/non-free amd64 Packages
Ign:12 http://http.kali.org/kali kali-rolling/non-free all Packages
Ign:13 http://http.kali.org/kali kali-rolling/non-free Translation-en_US
Ign:14 http://http.kali.org/kali kali-rolling/non-free Translation-en
Err:3 http://http.kali.org/kali kali-rolling/main amd64 Packages
  400  Bad Request
Ign:4 http://http.kali.org/kali kali-rolling/main all Packages
Ign:5 http://http.kali.org/kali kali-rolling/main Translation-en_US
Ign:6 http://http.kali.org/kali kali-rolling/main Translation-en
Err:7 http://http.kali.org/kali kali-rolling/contrib amd64 Packages
  400  Bad Request
Ign:8 http://http.kali.org/kali kali-rolling/contrib all Packages
Ign:9 http://http.kali.org/kali kali-rolling/contrib Translation-en_US
Ign:10 http://http.kali.org/kali kali-rolling/contrib Translation-en
Err:11 http://http.kali.org/kali kali-rolling/non-free amd64 Packages
  400  Bad Request
Ign:12 http://http.kali.org/kali kali-rolling/non-free all Packages
Ign:13 http://http.kali.org/kali kali-rolling/non-free Translation-en_US
Reading package lists... Done
W: The repository 'http://http.kali.org/kali kali-rolling Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: Failed to fetch http://http.kali.org/kali/dists/kali-rolling/main/binary-amd64/Packages  400  Bad Request
W: Failed to fetch http://http.kali.org/kali/dists/kali-rolling/contrib/binary-amd64/Packages  400  Bad Request
W: Failed to fetch http://http.kali.org/kali/dists/kali-rolling/non-free/binary-amd64/Packages  400  Bad Request
E: Some index files failed to download. They have been ignored, or old ones used instead.

I think there is some issue with apt-get packages as I am able to access Internet via browser and curl is working fine as well. I followed the following link here to reinstall apt packages but these .deb files are either has already updated or have become deprecated as they are not on this link anymore.

Any suggestions?

0

You might try to check date in your Kali Linux. Once I have Debian on VM and date was set about year or year and a half before actual date. I wasn't able to install or upgrade packages.

  • My vm date is fine. – aneela Jul 11 '17 at 11:17
0

According to the documentation:

The single most common causes of a broken Kali Linux installation are following unofficial advice, and particularly arbitrarily populating the system’s sources.list file with unofficial repositories. The following post aims to clarify what repositories should exist in sources.list, and when they should be used.

Any additional repositories added to the Kali sources.list file will most likely BREAK YOUR KALI LINUX INSTALL.

Check that your /etc/apt/sources.list has only these three lines:

deb http://http.kali.org/kali kali-rolling main contrib non-free
# For source package access, uncomment the following line
# deb-src http://http.kali.org/kali kali-rolling main contrib non-free

Check also that the directory /etc/apt/sources.list.d is empty.

  • These are the same repositories I already have in my sources.list as mentioned in question and yes sources.list.d is empty. – aneela Jul 11 '17 at 10:45
  • Can you wget http://http.kali.org/kali/dists/kali-rolling/Release ? – Ortomala Lokni Jul 11 '17 at 11:05
  • it says HTTP request sent, awaiting response... 400 Bad Request 2017-07-11 13:09:29 ERROR 400: Bad Request. after getting a connection. ` – aneela Jul 11 '17 at 11:16
  • However I need to authenticate first to use my wifi account, but curl command is working, so I dont think so thats the problem. – aneela Jul 11 '17 at 11:21
  • I am able to wget www.google.com but not that. – aneela Jul 11 '17 at 11:26
0

The problem I faced was my WIFI, I am not sure either its strength or outgoing,i incoming constraints. I started using LAN which was in different network and all works fine. Thanks everyone for trying help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.