I am setting up nixos.

Each time I change my configuration.nix and run nixos-rebuild switch, I must run the command loadkeys dvorak in order to use my preferred keyboard.

How can I configure nixos to load the dvorak keymap automatically?


Try the configuration option: i18n.consoleKeyMap = "dvorak";

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.