This is new to me from whatever version of kde I was using beforehand in debian 8. Previously, when I added an icon to the desktop, it would detect if it would have room at the size the icons were at, and then place itself accordingly, usually at the bottom of a column I have going. Now, in debian 9, it tries to squeeze in icons if there is any space at all by changing the icon size.

Here is a picture:

The problem at stake

As you can see, the opera icon just decided to squeeze itself into the top by changing it's size, which is undesirable

So, I have two questions:

  1. How can I change the size of individual icons?

  2. How can I change how the desktop automatically places icons to avoid this altogether?

1 Answer 1


I can't find an individual icon size setting in Kubuntu 19.10, but this thread from 2017 mentions a long-click (5 seconds left click) might help resize a desktop icon.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .