3

How can I make the desktop show icons again under 64bit Debian 9.0 Cinnamon?

I switched from the nemo file-manager to the nautilus one and now my desktop doesn't show any icons/folders and I can't right-click it either.

I already tried the gnome-tweak-tool which only has an option "Desktop"->"Icons on desktop" which I set to "On" and which didn't help. I also ran gsettings set org.gnome.desktop.background show-desktop-icons true and tried replacing "nemo" with "nautilus" in /usr/share/applications/x-cinnamon-mimeapps.list.

Also I'd like to know why desktop icons are apparently hidden by default when switching file-manager? Isn't that severely counterintuitive. Who wants the desktop to only display the wallpaper but no files on it? And is that just the case with nautilus?

Edit: I now switched from Cinnamon to KDE and from Nautilus to Dolphin: both are way better!

2
  • 1
    Same problem here. Killing nautilus and switching, with gnome-tweak-tool, icons on desktop on and off has worked for me. Aug 7, 2017 at 1:26
  • @QuoraFeans If that causes the desktop icons to show permanently (even after a restart) I would have marked this as the solution if you had posted it as an answer.
    – mYnDstrEAm
    Aug 7, 2017 at 11:26

2 Answers 2

1

I had some similar problems after upgrading from Debian8 (where I'd been using gnome flashback) to Debian9 where I've decided it was high time to make the jump to "modern" Gnome.

However, a big annoyance with the otherwise slick and shiny new gnome shell was no desktop icons and no amount of toggling the "Icons on desktop" in gnome-tweak-tool or hitting gsettings set org.gnome.desktop.background show-desktop-icons true seemed to affect it.

The breakthrough came from removing "Files" from the "Startup Applications" (also via gnome-tweak-tool). Next login, there were all my desktop icons, as expected.

I didn't then try putting "Files" back in "Startup Applications" (but with the desktop now appearing populated with a bunch of stuff, I don't see the value in also having a file-browser window come up by default on login).

No idea why doing this has the effect it does. Wild guess: some sort of race/conflict between nautilus-desktop and the nautilus instance started by "Files"?

1

Nautilus desktop support has been removed:
https://gitlab.gnome.org/GNOME/nautilus/-/issues/158#instructions.
But they left the setting.

These are at least 3 solutions:

  1. Use nemo-desktop (from nemo) to handle the desktop icons.
    Quote from the above link:
  1. Install nemo from your distribution's repositories. On Fedora, enter this command on the Terminal application:

sudo dnf install nemo

  1. Open a text editor and copy the following text into a new empty file:
    [Desktop Entry]
    Type=Application
    Name=Nemo
    Comment=Start Nemo desktop at log in
    Exec=nemo-desktop
    OnlyShowIn=GNOME;
    AutostartCondition=GSettings org.nemo.desktop show-desktop-icons
    X-GNOME-AutoRestart=true
    NoDisplay=true 
  1. Save the text file as ~/.config/autostart/nemo-autostart-with-gnome.desktop

And that's it! Next time you log in, nemo will automatically display icons over the desktop background. If you don't want to log out, you can also manually start it using the Alt+F2 prompt to run nemo-desktop

Optional step: In case you want Nemo to behave more similarly to nautilus desktop layout, you can enable the setting running this command on the terminal:

gsettings set org.nemo.desktop use-desktop-grid false

(On Debian use apt install nemo).

On my Debian 10 system I can see that the AutostartCondition=GSettings org.nemo.desktop show-desktop-icons line on the .desktop file doesn't change color as the other on gedit (text editor).
I need to remove that part to use it.

  1. Use an extension for desktop icons, like this for example: https://extensions.gnome.org/extension/1465/desktop-icons/.

  2. You can use the desktopfolder package.

There are also idesk and rox-filer https://wiki.debian.org/Openbox#Desktop_icons.

I tried idesk you have to manually set the icons.
It doesn't reflect the desktop folder.

I tried it on gnome and there it works bad.

Why has desktop support been removed?

The desktop was disabled for the default experience when GNOME 3 came out now 6 years ago, and so far has been mostly unmaintained. I spent around 3 months of work two years ago to try to save it somehow and did a rearchitectural work to try to separate the desktop from the Nautilus app so it won’t affect Nautilus development, and while it achieved some degree of separation, it didn’t achieve its main purpose and unfortunately brought even more problems than we had before. Now it has got to a point where the desktop is blocking us deeply in basically every major front we have set for future releases.

Also we notice that users rightfully have expectations for the desktop to work decently, and we acknowledge this is far from the reality and we are aware that the desktop is in a very poor state.

Full article here https://csorianognome.wordpress.com/2017/12/21/nautilus-desktop-plans/.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.