3

I have Oracle Solaris 11.3 (Intel) installed. In my server, I have three different NIC adapters placed. I have recently upgraded the firmware.

I want to know whether the firmware has been successfully upgraded and reflected in OS or not. How can I know the firmware version of NIC adapters in Solaris 11.3?

3
  • 1
    Intel or sparc?
    – Jeff Schaller
    Commented Jul 10, 2017 at 11:27
  • Intel. Sorry, I forgot to mention.
    – Amit24x7
    Commented Jul 10, 2017 at 11:30
  • Some drivers log information to /var/adm/messages on boot. Have you looked there? Commented Jul 14, 2017 at 12:59

2 Answers 2

2

According to the manual you might be able to see the firmware level using:

dladm show-link -p fw-vers

See man dladm for additional details.

Update:

Apparently the command should be dladm show-linkprop -p fw-vers. Sample output from a Dell server running Solaris 11.3:

root@myhost:~# dladm show-linkprop -p fw-vers
LINK     PROPERTY        PERM VALUE        EFFECTIVE    DEFAULT   POSSIBLE
net1     fw-vers         r-   5.0.1.5      5.0.1.5      --        -- 
net0     fw-vers         r-   5.0.1.5      5.0.1.5      --        --
3
  • Can you please provide few examples as this is not working in my case.
    – Amit24x7
    Commented Jul 17, 2017 at 12:18
  • Hi @Amit24x7, I updated the answer, can you please review?
    – Lambert
    Commented Aug 11, 2017 at 11:01
  • I tried the above command but last four columns are empty in my case. I'm running Solaris 11.3 on HPE servers.
    – Amit24x7
    Commented Aug 17, 2017 at 13:42
1

Have you tried modinfo <nic_module> ?

From the venerable Solaris docs: http://docs.oracle.com/cd/E19407-01/820-7898-11/z40001c91006813.html

EDIT:

Are you sure the driver version is not bumped when you install new firmware ?

List all pkg's that are related to ethernet drivers

# pkginfo | grep -i ethernet

Pick the one that matches your nic(s)

# pkginfo -x SUNWced
SUNWced  Sun GigaSwift Ethernet Adapter Driver
     (sparc.sun4v) 1.0,REV=2005.08.30.10.0

From https://www.veritas.com/support/en_US/article.000021363

If you could tell us which nics you have we could probably help more.

2
  • This will show the driver version but not the firmware. Apart from this, even I don't know few modules name. If you can help me with that also, that would be grateful.
    – Amit24x7
    Commented Jul 11, 2017 at 5:28
  • I have HPE 331FLR, HPE 530SFP+, and HPE NC365T NIC adapters. The drivers' name I have got by dladm show-phys command but still, I'm not getting the firmware version.
    – Amit24x7
    Commented Jul 12, 2017 at 6:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .