2

I've setup a ubuntu 64 bit VM (16.04) using Oracle VirtualBox. Using ftp, I am able to connect to the VM. I am also able to list (ls) the contents of the folder. However I am unable to put files to the VM.

C:\>ftp x.x.x.x
Connected to x.x.x.x.
220 (vsFTPd 3.0.3)
200 Always in UTF8 mode.
User (x.x.x.x:(none)): user
331 Please specify the password.
Password:
230 Login successful.
ftp> quote pasv
227 Entering Passive Mode (...)
ftp> put trnsfr.txt
200 PORT command successful. Consider using PASV.
550 Permission denied.

On ubuntu, I set permissions on folder to rwx on owner,group,all. I then modified /etc/vsftpd.conf as follows:

pasv_enable=YES
pasv_min_port=30000
pasv_max_port=30100
port_enable=yes
pasv_address=x.x.x.x

allowed data connections and restarted vsftpd daemon:

iptables -I INPUT -p tcp --destination-address 30000:30100 -j ACCEPT
/etc/init.d/vsftpd restart

but still permission error exists.

I then tried using filezilla: The connections is successful but again files can not be transferred: with dft settings in vsftpd:

Response:   550 Permission denied.
Error:     Critical file transfer error

with the settings in vsftpd.conf as above: the following is displayed in filezilla:

Error:  The data connection could not be established: WSAEADDRNOTAVAIL -     Cannot assign requested address

I believe the problem is to do with the data connection - but am not sure what/how to resolve?

0

Do you have write_enable=yes in vsftpd.conf? The default is no.

Change that and try again. I think the other error is just a result of that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.