2

I use LXTerminal 0.20. with XFCE 4.12.2 on Linux Mint 18.2 (upgraded from 18.1).

When I copy text in some desktop app and paste it into an LXTerminal session, I get 0~ and 1~ prepended and appended, respectively, to the text. So,

Hello world

becomes

0~Hello World1~

This doesn't happen with XFCE4's "native" terminal app (xfce4-terminal), so not the same issue as in this question - and not resolved by the answer there. It also doesn't happen if I copy the text to apps with GUI (i.e. the text itself, in the clipboard, is fine).

Why is this happening and what can I do to avoid it?

  • Something's enabled bracketed paste, but the shell (or whatever you're pasting into) doesn't understand it. – Thomas Dickey Jul 9 '17 at 20:36
  • @ThomasDickey: So, how can I disable it, or perhaps - how can I make my shell understand it? (I'm guessing only the first option is actually relevant). – einpoklum - reinstate Monica Jul 9 '17 at 20:53
  • @JeffSchaller: Not a dupe, since I don't see that problem with xfce4-terminal. Please read more carefully before marking as a dupe... – einpoklum - reinstate Monica Jul 9 '17 at 21:14
  • What software (shell?) is running in the terminal when the pasting happens? – thrig Jul 9 '17 at 21:19
  • Thought the other answer showed how to turn off bracketed paste. – Jeff Schaller Jul 9 '17 at 21:25
0

This helped, not sure why:

  1. In XFCE4, open Preferences | Input Method | Language.
  2. Change your region to something else.
  3. Press "Apply to entire system".
  4. Change it back.
  5. Press "Apply to entire system".
  6. Close LXTerminal and re-start it.

That made the problem go away for me. I'm sure there's a better answer, but if it works, it works.

  • 1
    I'm almost certain that 1-5 don't play any role here. Any newly opened terminal works correctly at the beginning, but due to a bug in older VTE versions, terminals "break" relatively easily during normal operation. – egmont Nov 25 '17 at 0:03
0

I've just had this issue, I'm using zsh as shell and for me it was something I had to fix in my .zshrc by adding:

unset zle_bracketed_paste

This made new terminal windows not enter bracketed paste mode by default.

0

Use "reset" command to reinitialize your terminal.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.