2

I keep getting this error, and I think it's because my JobDef contains a default schedule:

31-Jan 23:30 bareOSdirector JobId 67: Error: Bareos bareOSdirector 16.2.4 (01Jul16):
  Build OS:               x86_64-pc-linux-gnu debian Debian GNU/Linux 7.0 (wheezy)
  JobId:                  67
  Job:                    RestoreFiles.2017-01-31_23.30.32_23
  Restore Client:         bareOSdirector-fd
  Start time:             31-Jan-2017 23:30:52
  End time:               31-Jan-2017 23:30:52
  Elapsed time:           0 secs
  Files Expected:         0
  Files Restored:         0
  Bytes Restored:         0
  Rate:                   0.0 KB/s
  FD Errors:              2
  FD termination status:  
  SD termination status:  
  FD  Secure Erase Cmd:   <NULL>
  SD  Secure Erase Cmd:   <NULL>
  Termination:            *** Restore Error ***

If I want to keep the default value of which schedule to use in my JobDef, what value do I need to override the RestoreFiles job's Schedule with, to prevent it from being run?

JobDefs {
  Name = "DefaultJob"
  Type = Backup
  Level = Incremental
  Messages = "standard"
  Storage = "bareOSdirector_FileStorage"
  Pool = "Daily"
  FullBackupPool = "Full"
  IncrementalBackupPool = "Incremental"
  DifferentialBackupPool = "Differential"
  FileSet = "SelfTest"
  Schedule = "WeeklyCycle"
  JobDefs = "DefaultJob"
  WriteBootstrap = "/var/lib/bareos/%c.bsr"
}

Job {
  Name = "RestoreFiles"
  Type = Restore
  Messages = "standard"
  Storage = "bareOSdirector_FileStorage"
  Pool = "Incremental"
  Client = "bareOSdirector-fd"
  FileSet = "LinuxAll"
  JobDefs = "DefaultJob"
  Where = "/tmp/bareos-restores"
  Schedule = ????
}
0

I was able to skip over the RestoreFiles (disable it) by setting Enabled = "no" in the Job, it no longer appears in the schedule after I do that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.