4

I'm on Arch Linux and have IntelliJ's community edition (2017.1.4) installed. The main font of the IDE seems to be missing.

The following screenshot shows that the font of the menu and status bar is gone while the text of the tip of the day is rendered fine.

My desktop environment is LXDE.

How can I debug and fix this?

screenshot_of_missing_font


uname -a:

Linux marathon 4.11.9-1-ARCH #1 SMP PREEMPT Wed Jul 5 18:23:08 CEST 2017 x86_64 GNU/Linux

Edit: When reinstalling IntelliJ, I noticed this warning:

Running IntelliJ IDEA using OpenJDK is officially unsupported because of possible performance and graphics problems

Consequently I installed Oracle's JDK but this didn't affect the font rendering.

java -version:

java version "1.8.0_131" Java(TM) SE Runtime Environment (build 1.8.0_131-b11) Java HotSpot(TM) 64-Bit Server VM (build 25.131-b11, mixed mode)

archlinux-java status:

Available Java environments: java-8-jdk (default)

echo $JAVA_HOME:

/usr/lib/jvm/java-8-jdk/

  • 1
    Try running it in Xfce4. Xfce4 has a settings manager that may influence the look and feel of GUI applications. (Just like GNOME and KDE). Xfce4 is a small and well tested desktop environment that usually takes the WM/DM out of the equation when troubleshooting. – Alexander Jul 16 '17 at 11:49
  • 1
    @Alexander: Wow, switching to Xfce4 fixed the problem. Since I'm not married to LXDE, my problem is solved, thank you! I'm still curious how this font issue can be fixed in LXDE, but if you want you can post your comment as an answer. – Matthias Braun Jul 16 '17 at 14:25
  • Have you tried to change fonts in Intellij settings? – user996142 Jul 16 '17 at 21:42
  • @user996142 No, I couldn't find those settings since none of the menus had text :-) But switching from LXDE to Xfce4 solved the problem. – Matthias Braun Jul 17 '17 at 6:51
1
+50

You can debug this issue by first running the same application under Xfce4. Xfce4 is a stable, solid, light and well-tested desktop environment. It is helpful as a first step in troubleshooting the issue. Xfce4 has its own font settings.

Since switching to Xfce4 solved the issue, you can fix this issue by continuing to use Xfce4.

  • 2
    Undeleted since the asker specifically requested it be posted as an answer – Michael Mrozek Jul 17 '17 at 19:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.