If I run sudo freshclam I get this error:

ERROR: Can't open /var/log/clamav/freshclam.log in append mode (check permissions!).
ERROR: Problem with internal logger (UpdateLogFile = /var/log/clamav/freshclam.log).

I went to /var/log/clamav to check it's permissions, but there isn't a clamav directory there. I tried sudo locate freshclam.log but nothing came back.

I'm running Debian 8 Jessie and ClamAV 0.99.2. I installed ClamAV using sudo apt-get install clamav. Clamscan works fine,

Any ideas?


Perhaps the same process is already running automatically stop it with the command:

sudo /etc/init.d/clamav-freshclam stop

and try again to manually with the command:

sudo freshclam
| improve this answer | |
  • 1
    Hi, gave that a try and got the same error message? – tomh1012 Aug 9 '17 at 12:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.