I have a Manjaro Linux installation and after a pacman - syu update (potentially updating the kernel) , and restarting my computer, I get the following error message after grub:

[ 4.896409] Initramfs unpacking
failed: read error  
:: running early hook [udev]  
:: running early hook [lvm2] 
:: running hook [udev] 
:: Triggering uevents... 
:: running hook [plymouth] 
:: Loading plymouth... done
:: running hook [plymouth-encrypt] 
:: running hook [resume] 
ERROR: resume: no device specified for hibernation
ERROR: device '' not found. Skipping fsck
:: mounting '' on real root
You are now being dropped into an emergency shell. 
sh: can't access tty; job control turned off
[rootfs  ] #

At the shell, if I type, no letters are appearing on the screen, leading me to believe it is not registering keyboard input. Also note that my hard drive is encrypted. At grub, I have the option for Manjaro Linux kernel 4.9.34-1 x64 and 4.9.33-1-rt23 x64 (and respective fallback initramfs) which I have tried. If there is any more information that I can provide, I am willing to.

  • I have a similar problem. Have you been enable to resolve this? – k.stm Jul 23 '17 at 12:23

I had a similar problem, when trying to bring up a new machine in Arch. My problem was that my initramfs was missing all modules, but you seem to have some, so it's not the identical problem, but I think the solution will be the same.

See your first error is there in the second line of your posted log:

failed: read error

See how it's failing to read your initramfs, so it looks like that got corrupted somehow, and it's given up reading it. You need to rebuild your initramfs.

I did that like this, after I'd booted to a rescue DVD, and mounted my system in /mnt and chrooted into that:

mkinitcpio -p linux

You're best off updating your grub.cfg at this point, I think (though I'm new to grub, so don't quote me on that). This, from the same environment should do that for you:

grub-mkconfig -o /boot/grub/grub.cfg

When I ran that I saw new messages about it finding my kernel and initramfs, so I think I'd managed to run it with an incorrectly populated /boot folder last time. You may not have that problem, but if you've no hand-crafted edits you want to keep, I'd regenerate it just out of habit.

Hope that helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.