0

I would like nano to soft-wrap at 80 characters. That is, as I keep typing, the text should flow to the next line beyond 80 characters, without nano insert a \n newline at 80 characters.

set softwrap
set tabsize 4
set tabstospaces
set fill 72

However, this inserts a newline after each line, when tested with cat.

How do I softwrap and fill simultaneously?

0

Your 'set fill' command asks for hard wrapping at column 72 (I think). Have you actually tried this up to column 80?

You need to lose the 'set fill' command, really.

  • If I get rid of set fill, my lines will go from the left extreme of my screen to the right extreme, which I don't want. Is there a way to force both options? – Karthik Nishanth Jul 8 '17 at 17:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.