I created live usb using a live image of debian stretch on kernel 4.9.0-3-adm64, and then installed persistence image file on root of data partition which contains /boot/grub and /live/filesystem.squashfs.

Now grub is able to boot debian in persistence mode by following kernel commands:

linux /live/vmlinux-4.9.0-3-amd64 boot=live components persistence
initrd /live/initrd.img-4.9.0-3-amd64

Persistence storage setup works as expected, but I'm looking to boot the filesystem in read-only mode while using persistence storage, live-boot man page (here) introduces persistence-read-only:


Filesystem changes are not saved back to persistence media. In particular, overlays and netboot NFS mounts are mounted read-only.

and Debian Live Systems Manual doesn't say too much about this.

I tied following kernel options, none of them work:

# it not even load persistence image! also tried with "persistence-label=persistence"
linux /live/vmlinux-4.9.0-3-amd64 boot=live components persistence persistence-read-only
initrd /live/initrd.img-4.9.0-3-amd64

# loads persistence image, but it's not ro 
linux /live/vmlinux-4.9.0-3-amd64 boot=live components ro persistence
initrd /live/initrd.img-4.9.0-3-amd64

When searching boot logs for peristence and persistent keywords, I cannot find anything more than the above kernel command lines.

I also read this brilliant post at Debian forums, but even his/her command line doesn't work for me.

Question in short:

How can I boot Debian live image 4.9.0-3, loading persistence image, but not writing back changes to it?!

  • Why would you configure persistence and then try to force not to write back filesystem changes? I don't understand your goal. Do you realize that you can use the live Debian and make changes to the root file system without persistence per definition of "live"? – schlimmchen Jul 30 '17 at 21:01
  • Here my goal is to not write back changes by default, maintaining always a fresh boot while saving occasionally changes manually or from certain boots. I use persistence definition and not a filesystem partition because filesystem.squashfs compresses my large filesystem very well. From debian live-boot I realize that there is option for this goal, but unfortunately the option seems to not work in my setup. – 2i3r Jul 31 '17 at 3:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.