I alt-clicked on a window's title bar and removed the bar by clicking "No border" but now I have no accessible means to restore that window's title bar. Is there a way to open KWin for that specific window? What are my options for restoring the window's border? (Plasma 5, if it's version-specific.)


Check in Systemsettings > Application Style > Window Decorations

there should be an option to set borders.

or edit the following config file: ~/.config/kwinrc

look for the line: BorderlessMaximizedWindows=true

and either change it to false or comment it out.

| improve this answer | |
  • Neither of these apply to me. I'm also on Plasma 5. There's no option to set borders, and the line in kwinrc already doesn't exist. – chreekat Jun 29 '18 at 13:47

Focus window:

Alt+F3 ⇒ "more actions" ⇒ uncheck "no border"

| improve this answer | |

press Alt+F3 on window with focus:

choose menu item(s): more actions > [deselect] 'no borders'

You should get a message dialog when you 'hide border' that reads something like ... blah, blah. use Alt+F3 to show menu allowing you to do the above with your mouse.

If you are Not getting the message do this (utf-8 editor!): Edit file: ~/.kde4(.kde)/share/config/kwin_dialogsrc Change or Add the Line(s):

[Notification Messages]

Save, Done. (no restart necessary)

| improve this answer | |

I needed to do the same thing, but I didn't find anything relevant in ~/.config/kwinrc.

I found the application-specific settings in ~/.config/kwinrulesrc. I removed them with Vim, and restarted kwin_x11, and restored the border on the program I had previously removed the border from.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.