1

I'm trying to disable time sync between a Fedora 25 vbox guest (with Guest Additions installed) and a Fedora 25 host. VirtualBox version is 5.1.22 r115126. So far I've tried the following at the same time without success:

  1. Issue the commands:

    VBoxManage setextradata <YOUR_VM_NAME> "VBoxInternal/Devices/VMMDev/0/Config/GetHostTimeDisabled" 1
    
    VBoxManage setextradata <YOUR_VM_NAME> "VBoxInternal/TM/TSCTiedToExecution" 1
    

as suggested by https://superuser.com/questions/742924/is-it-possible-to-get-a-virtualbox-vm-always-start-from-same-time-if-so-how

  1. Add the option --disable-timesync to vboxadd-service

as indicated by https://www.virtualbox.org/ticket/2928

  1. Disable all network adapters.

Am I missing anything? Thanks in advance.

  • 1
    Have a look at forums.virtualbox.org/viewtopic.php?f=1&t=49016 where this is discussed. As you do not shut down the guest system but use snapshots instead, there was a way. I don't know if something changed in the meantime. – mviereck Jul 7 '17 at 15:15
  • Thanks, as said in that thread restoring a snapshot taken when the vm is powered on worked, but shutting it down and then on didn't. – Asta86 Jul 7 '17 at 17:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.