1

I have Arch installed on my Lenovo T440p, and I'm trying to get the Gnome desktop environment to work.

I have edited /etc/X11/Xwrapper.config to add: allowed_users=anybody

I made my user and added it to wheel group. When I am logged on as the user and type startx, X-server crashes with error:

/dev/tty1: Permission denied

  • Can you say more about what you did since the Arch wiki entries for GDM and GDE do not mention editing Xwrapper.config. What command do you run (and as what user) that causes the crash. – StrongBad Jul 7 '17 at 15:24
  • 1
    First, check that your really have Xwrapper and it has suid bit. Is your X or Xorg points to wrapper? Second, it is much better use display manager instead of running X directly. – user996142 Jul 7 '17 at 16:06
  • Arch changes faster than its documentation. Can you explain where/how to find the Xwrapper file that needs the suid bit set? How do I find out if X or Xorg points to the wrapper? – McPedr0 Jul 24 '17 at 18:21
  • I like to run startx before setting up a display manager just because then I have less parts involved if my system fails to boot to a graphical login screen. In any case, I've been using Arch for more than 5 years, and installed a dozen or so systems during that time, I've never had to modify anything in /etc/X11/Xwrapper.config in order to run startx as a non-root user. Reading the manpage the default (allowed_users=console) should be enough, do you also set needs_root_rights? – Magnus Aug 9 '17 at 8:30
  • '$ cat /etc/X11/Xwrapper.config' 'allowed_users=console' 'needs_root_rights=no' I think it might have something to do with the recent changes in xorg-server respository [reddit.com/r/archlinux/comments/69r15f/xorgserverutils_removed/… Maybe I have the wrong hardware settings...? – McPedr0 Aug 9 '17 at 17:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.