1

Lubuntu is not changing the bios date-time when I set the date-time manually using the Time and Date Application. Due to which, when I reboot it synchronises the time with the wrong time in bios.

I am not using ntp.

I tried putting the following command on various places.

hwclock --systohc --localtime

I placed it in /etc/lightdm/lightdm.conf int session-cleanup-script (P.S called the command using script);

I placed it in /etc/init.d/ and created symlinks in /etc/rc0.d and /etc/rc6.d/.

OS is Lubuntu 16.04

I cannot issue command from terminal as the OS will be deployed to non-technical users.

  • What have you tried? 1. List the commands that you issued to the shell. 2. Show the contents of the ntp.conf file by typing: cat /etc/ntp.conf – AfroJoe Jul 6 '17 at 12:31
  • Edited the question – Antony Jul 6 '17 at 12:47
  • are you testing on metal or inside a VM ? – Massimo Jul 7 '17 at 0:24
  • is it possible the desktop ... Gnome clock is not updating the new time ? check if hwclock shows the correct time – Massimo Jul 7 '17 at 0:25
  • I have tested on both in vm and metal. I checked using timedatectl | head -3 command and can confirm that system time is changing but not the hwclock – Antony Jul 7 '17 at 7:40
0

I solved it by modifing the /etc/sudoers file by appending the following.

%sudo ALL = NOPASSWD: /sbin/hwclock

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.