1

I am using minimal debian(jessie) with lxde-common installed for UI application view.

With this configuration I am trying to run "GKSU" with its configured shortcut key. it works as expected. However, the user password entry box for GKSU contains 2 option under remember password, which i want to disable completely across system

enter image description here

Option 1: Save for session

Option 2: save for Keyring

For my application use case I do not want these option. Need some guidance for these setting changes

Mentioned are some of trials i have done from end

Command used for executions:

gksu -u test /usr/bin/xterm

Trail 1 : gconftool (Result : failed)

gconftool-2 --direct --config-source xml:readwrite:/etc/gconf/gconf.xml.mandatory --type bool --set /apps/gksu/save-to-keyring false

Trail 2: Disabling daemon execution permission

chmod +x $(type -p gnome-keyring) (Result : failed)

Trial 3: Commenting of pam_gnome_keyring under lightdm pam.d

In /etc/pam.d/lightdm two lines are commented (Result : "save for Keyring" was disabled)

#auth  optional pam_gnome_keyring.so
#session optional        pam_gnome_keyring.so auto_start

I am still not able to find a solution on disabling "Save for session" feature. Request some guidance

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.