3

I am working on Freescale T2080 RDB. I got CentOS for PPC64 architecture from this link.

I made a bootable SD card with the CentOS minimal ISO using the following command:

dd bs=4M if=CentOS-7-AltArch-ppc64-Minimal-1611.iso of=/dev/sdc

When I try to boot the freescale board using this SD card I get following message and error:

==> bootd
Device: FSL_SDHC
Manufacturer ID: 74
OEM: 4a60
Name: USDU1
Tran Speed: 50000000
Rd Block Len: 512
SD version 3.0
High Capacity: Yes
Capacity: 15.1 GiB
Bus Width: 4-bit
Erase Group Size: 512 Bytes
** Invalid partition 2 **
Unknown command '/boot/uImage' - try 'help'
** Invalid partition 2 ** 
WARNING: adjusting available memory to 30000000
Wrong Image Format for bootm command
ERROR: can't get kernel image!

Where am I going wrong? The freescale board seems to be looking for uImage file in /boot directory but the CentOS structure in the SD card is different. Is CentOS PPC64 supported by Freescale T2080 RDB?

EDIT: I also tried creating the bootable SD card using Rufus software but I am facing the same problem.

1
  • I don't think you can put an ISO image on an SD card ... you need an SD card image - what other image files do you have available? Jul 7, 2017 at 3:38

3 Answers 3

2
+50

sdc1 is wrong. Use sdc. Otherwise you're just using existing partition table on the sd card.

dd bs=4M if=CentOS-7-AltArch-ppc64-Minimal-1611.iso of=/dev/sdc

A related example can be seen here, on the CentOS wiki, writing from ISO to USB. It's x86 rather than ppc64 and it's USB rather than SD, but concept remains the same. https://wiki.centos.org/HowTos/InstallFromUSBkey

Of particular note is the line You must write to the entire device and not a partition on it (so, /dev/sdb not /dev/sdb1)

7
  • As mentioned in my post, I later created the bootable sd card using Rufus software but faced the same problem.
    – Jay
    Jul 9, 2017 at 16:20
  • OK. So have you tried using the dd command I suggested ?
    – steve
    Jul 9, 2017 at 16:30
  • I'll try as you suggested.
    – Jay
    Jul 9, 2017 at 16:31
  • I tried as you had suggested. The error is different this time. There is an extra line: " Unknown command '/boot/uImage' ". The freescale board seems to be looking for uImage file in /boot directory but the CentOS structure is different. I'll look into this further and update.
    – Jay
    Jul 13, 2017 at 3:24
  • 1
    I have updated the question.
    – Jay
    Jul 14, 2017 at 3:38
1

According to output you gave now, your device expecting U-Boot, but the image may have only "normal" kernels and not uImage.

To clarify, you may refer to: image-vs-zimage-vs-uimage

So, naturally, you have at most two choices:

  • search for U-Boot ISO;
  • switch your board to do not use U-Boot (cause if it is possible at all for your board).

Update:

Most probably you just need to use not "minimal" ISO, but complete one. See recommendations from here: https://github.com/umiddelb/aarch64/wiki/Install-CentOS-7-on-your-favourite-ARMv8-ARM64-AArch64-board

Most ARM single board computers are shipped with a vendor specific bootloader (mostly u-boot) and Linux kernel image. You may take an existing Debian/Ubuntu/Archlinux disk image and wipe out the root file system contents (but leaving the kernel image (/boot), the kernel modules (/lib/modules) and the firmware files (/lib/firmware) untouched).

0

Following is the reply I got from CentOS mailing list:

The CentOS 7 ppc64 and ppc64le variants are supposed to be installed on IBM Power (or compatible boxes, like Tyan or others, from the OpenPower consortium)

Nothing would work "by default" from a CentOS side, but something could probably be done if you build a RootFS composed with the ppc64/ppc64le tree.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .