0

I did a fresh install of Debian 9 XFCE on my desktop computer. Afterwards, I noticed a line running horizontally through the bottom of the screen. I also upgraded my laptop from Debian 8 to Debian 9 and have the same problem. I also installed GNOME on both computers, but it does not have this problem. I'm curious if it has something to do with how XFCE renders to the screen.

As suggested, here is the inxi -b output.

System:    Host: debian9-desktop Kernel: 4.9.0-3-amd64 x86_64 (64 bit)
           Desktop: Xfce 4.12.3 Distro: Debian GNU/Linux 9 (stretch)
Machine:   Device: desktop Mobo: ASRock model: 970 Extreme3 R2.0
           BIOS: American Megatrends v: P1.60 date: 06/05/2014
CPU:       Octa core AMD FX-8320 Eight-Core (-MCP-) speed/max: 1400/3500     MHz
Graphics:  Card: NVIDIA GF119 [GeForce GT 610]
           Display Server: X.Org 1.19.2 drivers: nouveau (unloaded: modesetting,fbdev,vesa)
           Resolution: 1920x1080@60.00hz
           GLX Renderer: Gallium 0.4 on NVD9 GLX Version: 3.0 Mesa 13.0.6
Network:   Card-1: Qualcomm Atheros AR93xx Wireless Network Adapter
           driver: ath9k
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet  Controller
           driver: r8169
Drives:    HDD Total Size: 2250.5GB (1.1% used)
Info:      Processes: 201 Uptime: 1:06 Memory: 826.0/16008.8MB
           Client: Shell (bash) inxi: 2.3.5

Screen shot:

enter image description here

  • Sorry I didn't post the screen shot correctly: !Screen shot – Pura Vida Jul 6 '17 at 2:42
  • You're not posting any meaningful information. Try installing inxi then run and post output of: inxi -b – Lizardx Jul 6 '17 at 2:47
  • Thanks for the suggestion. I wasn't sure what type of information to post. – Pura Vida Jul 6 '17 at 3:31
  • That's a hard one to figure out. I had issues with the way xfce launched itself that led to the screen being offset, but your issue is not related to that. I'm tempted to say this is a nouveau issue, but the fact that gnome is not experiencing this issue makes me suspect it's something else. In xfce settings, display, see what happens if you change the frequency. However, 60hz seems totally normal to me. You aren't by chance using gnome wayland are you? if so, that would account for the difference. – Lizardx Jul 6 '17 at 3:36
  • To be clear, when you say you installed gnome, you mean you installed the gnome packages onto stretch, and are logging into either xfce or gnome from the same login screen? Not, that is, a different distribution, with a different nouveau driver and xorg version, that is. Also, try to see if you make the background solid blue or red or purple if that line still appears, in case it's an issue with how xfce is using your background image. – Lizardx Jul 6 '17 at 3:46
0

Go to xfce-settings -> window manager tweaks -> compositor -> untick "show shadows under dock". Looks like it has something with cairo dock is rendered.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.