0

I'm trying to instal Krita on Linux Ubuntu 16.4
by following this:

sudo add-apt-repository ppa:kubuntu-ppa/backports 
sudo apt-get update 
sudo apt-get install krita    

I'm getting this when I try second command (for update):

    Err:1 http://rs.archive.ubuntu.com/ubuntu xenial InRelease                               
  Could not connect to 172.16.0.3:8080 (172.16.0.3), connection timed out
Err:2 http://rs.archive.ubuntu.com/ubuntu  xenial-backports InRelease                 
  Unable to connect to 172.16.0.3:8080:
Err:3  http://rs.archive.ubuntu.com/ubuntu  xenial-updates InRelease                  
  Unable to connect to 172.16.0.3:8080:
Err:4 http://archive.canonical.com/ubuntu  xenial InRelease                             
  Could not connect to 172.16.0.3:8080 (172.16.0.3), connection timed out
Err:5 http://dl.google.com/linux/chrome/deb stable InRelease                             
 Could not connect to 172.16.0.3:8080 (172.16.0.3), connection timed out
Err:6 http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu xenial InRelease              
  Could not connect to 172.16.0.3:8080 (172.16.0.3), connection timed out
Err:7  http://security.ubuntu.com/ubuntu xenial-security InRelease                        
  Could not connect to 172.16.0.3:8080 (172.16.0.3), connection timed out
Reading package lists... Done             
W: Failed to fetch  http://rs.archive.ubuntu.com/ubuntu/dists/xenial/InRelease   Could not connect to 172.16.0.3:8080 (172.16.0.3), connection timed out
W: Failed to fetch  http://rs.archive.ubuntu.com/ubuntu/dists/xenial-backports/InRelease  Unable to connect to 172.16.0.3:8080:
W: Failed to fetch   http://security.ubuntu.com/ubuntu/dists/xenial-security/InRelease  Could not connect to 172.16.0.3:8080 (172.16.0.3), connection timed out
W: Failed to http://archive.canonical.com/ubuntu/dists/xenial/InRelease  Could not connect to 172.16.0.3:8080 (172.16.0.3), connection timed out
W: Failed to fetch http://rs.archive.ubuntu.com/ubuntu/dists/xenial-updates/InRelease  Unable to connect to 172.16.0.3:8080:
W: Failed to fetch http://dl.google.com/linux/chrome/deb/dists/stable/InRelease   Could not connect to 172.16.0.3:8080 (172.16.0.3), connection timed out
W: Failed to fetch http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu/dists/xenial/InRelease Could not connect to 172.16.0.3:8080 (172.16.0.3), connection timed out
W: Some index files failed to download. They have been ignored, or old ones used instead.

-I'm not using proxy
-The first command also doesn't work:

gpg: keyserver receive failed: keyserver error

-The third command too, but I won't type anything about third, because I think the main problem is:

Could not connect to 172.16.0.3:8080 (172.16.0.3), connection timed out

-I tried this (so I think a firewall is not problem):

sudo ufw disable

What should I do to be able to update OS, and to be able to install Krita (or any other application)?

  • It would seem that you are in fact configured to use a proxy. – ivanivan Jul 6 '17 at 4:35
  • All I know basically is that you don't appear to have direct Internet access (if at all). Do some things work online? What DNS server are you using? Can you ping 8.8.8.8? – Julie Pelletier Jul 6 '17 at 5:28
  • @ivanivan I turned off proxy in browser preferences/advanced/network/settings , but didn't in computer settings/network/network proxy. So I turned it to "none" but still had the same problem. – greenera Jul 6 '17 at 12:20
  • @JuliePelletier yes, I have Internet acces, and other answers are in comment under (under Philip answer). – greenera Jul 6 '17 at 12:36
  • A proxy wasn't turned off well. – greenera Aug 28 '17 at 9:58
1

Something is broken with your DNS. rs.archive.ubuntu.com should resolve to 147.91.175.253, but in your environment you are getting 172.16.0.3, an address in RFC 1918 space - i.e. an address intended for use within your local network. Looking further down the log, you are getting 172.16.0.3 for every DNS lookup.

Check your /etc/resolv.conf and see what you're using for a DNS server. If you're not on a corporate network where it might get you into trouble, start using Google's DNS server 8.8.8.8 instead. If you are on a corporate network, talk to your IT folk.

| improve this answer | |
  • this is what i got: cat /etc/resolv.conf# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8) # DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN nameserver 127.0.1.1 then I tried ping 8.8.8.8 and waited till: 64 bytes from 8.8.8.8: icmp_seq=2180 ttl=60 time=100 ms ^C --- 8.8.8.8 ping statistics --- 2180 packets transmitted, 2164 received, 0% packet loss, time 2182108ms rtt min/avg/max/mdev = 12.981/88.989/1500.079/150.736 ms, pipe 2 [next comment, don't have space here] – greenera Jul 6 '17 at 12:29
  • "nameserver 127.0.0.1" means you're using a DNS server on your local machine. Either you set this up, in which case you need to fix your configuration, or your system admin set this up, in which case you need to talk to them. – Philip Kendall Jul 6 '17 at 15:17
  • And how can I fix it? If I understood the problem is the nameserver and I have to change it? Or can the problem be the fact that I'm on wi-fi internet (while computer is directly connected to router) ? – greenera Jul 7 '17 at 15:06
  • That depends how you want to fix it. You could fix the configuration of your locally installed nameserver, or you could change your DHCP settings on your network to use a good nameserver. With all due respect, it doesn't sound like you should be running your own nameserver, so I'd reset your network to factory defaults and start again. – Philip Kendall Jul 8 '17 at 6:56
  • Well I tried "sudo iptables -F" and I'm still getting : "Unable to connect to 172.16.0.3:8080:" Then I tried to connect with cable (not wi-fi) and nothing's change about "sudo apt-get update", but... – greenera Jul 13 '17 at 20:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.