When I finished using "setup" to set my IP address to be static to, and restarted network service, there was a problem.

Error: No suitable device found: no device found for connection 'System eth0'.

Please refer attached file as the reference for the same.

error shows in picture


Problem: You don't have eth0 network interface. You have only eth4 as ifconfig says.

Solution: Rewrite eth0 to eth4 in your network config file.

  • when i tried to use eth4 , the new file is created and it didn't work – user3786256 Jul 5 '17 at 21:50
  • @user3786256 You must edit it in file, where you set your static IP. – BlueManCZ Jul 5 '17 at 21:51
  • I tried that also but didn't work – user3786256 Jul 5 '17 at 21:55
  • @user3786256 Ok, so edit you answer above and append file, where you changed network setting or screenshot of it. – BlueManCZ Jul 5 '17 at 22:02
  • Please include the contents of the following files: /etc/udev/rules.d/70-persistent-net.rules, /etc/sysconfig/networking/profiles/default/ifcfg-eth*, /etc/sysconfig/network-scripts/ifcfg-eth* (note wildcards). – Deathgrip Jul 5 '17 at 22:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.