0

I've installed Arch 2017.07.01 on a micro SD card in my Dell Chromebook 13 using this guide, and I'm using John Lewis' SeaBios to dual boot. I can successfully get into the boot menuand select the micro sd to boot from, but I then get a Welcome to GRUB! message, and, instead of a GRUB console, i get a few lines of white distortion on top of my screen, with the boot menu still frozen in the background. I believe the distortion is the console outputting incorrectly as typing seems to change it, and it disappears after a while, reappearing when i move the mouse or type, like the screen falling asleep and waking up.

I've already tried doing a full reinstall of arch, commenting out GRUB_HIDDEN_TIMEOUT and GRUB_HIDDEN_TIMEOUT_QUIET, and changing GRUB_GFXMODE to 640x480, but nothing had worked.

Any ideas?

0

I see that this is very late, but I want to leave an answer in case you still have this problem, or anyone else comes across it. What worked for me was doing everything OP did(commenting out GRUB_HIDDEN_TIMEOUT and GRUB_HIDDEN_TIMEOUT_QUIET, uncommenting GRUB_GFXMODE=640x480), but also uncommenting GRUB_TERMINAL=console. For those who don't know know these are all changes in /etc/default/grub. After you change that file you always have to run sudo update-grub. This worked on the Chromebook Pixel 2 but it might work on other chromebooks as well.

see this question as a reference.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.