1

Today morning I was browsing the internet with Chromium and it closed out of nowhere. I went to open it again but it opens very briefly (less than a second) and then it closes back again. This has never happened before.

The only way I can open it back up is by completely deleting ~/.config/chromium/Default. Then I can open it back again but it closes again within a few minutes.

Things I've tried:

  • I have purged and reinstalled Chromium
  • I have deleted every file that was crated within the time frame that the problem started (from ~/.config/chromium/)
  • I have tried browsing only different websites to see if it's some specific kind of website that triggers it. Apparently the website I am in doesn't make a difference.

For the moment I'm using Chrome, but I really would like to get back to using Chromium.

If I open Chromium with a terminal these are the messages I get (keep in mind that as far as I know the first two messages are normal and happen even when Chromium works):

Gkr-Message: couldn't connect to dbus session bus: Failed to connect to socket /tmp/dbus-FvyymbKhrF: Connection refused

(chromium-browser:29177): LIBDBUSMENU-GLIB-WARNING **: Unable to get session bus: Could not connect: Connection refused
Received signal 11 SEGV_MAPERR 000000000010
#0 0x7f0dc4dcc425 base::debug::StackTrace::StackTrace()
#1 0x7f0dc4dcc80b <unknown>
#2 0x7f0dc50f7390 <unknown>
#3 0x562a8f85edc8 <unknown>
#4 0x562a8f861656 <unknown>
#5 0x562a8f861df9 <unknown>
#6 0x562a8f862143 <unknown>
#7 0x7f0dc4e47821 <unknown>
#8 0x7f0dc4dcdeea base::debug::TaskAnnotator::RunTask()
#9 0x7f0dc4df6e90 base::MessageLoop::RunTask()
#10 0x7f0dc4df897d base::MessageLoop::DeferOrRunPendingTask()
#11 0x7f0dc4df983d <unknown>
#12 0x7f0dc4dfa300 base::MessagePumpLibevent::Run()
#13 0x7f0dc4df5f15 base::MessageLoop::RunHandler()
#14 0x7f0dc4e20628 base::RunLoop::Run()
#15 0x7f0dc4e4ce36 base::Thread::ThreadMain()
#16 0x7f0dc4e47726 <unknown>
#17 0x7f0dc50ed6ba start_thread
#18 0x7f0dae79c3dd clone
  r8: 000000000000002e  r9: 0000562a912b56ec r10: 0000000000000000 r11: 00007f0dae829f50
 r12: 00007f0d23ffcff0 r13: 0000000000000008 r14: 0000000000000008 r15: 00007f0d23ffceb0
  di: 0000000000000000  si: 00007f0d23ffceb0  bp: 00007f0d23ffcf00  bx: 00007f0d23ffceb0
  dx: 000000000000006b  ax: 0000000000000000  cx: 00007f0d0800a790  sp: 00007f0d23ffce60
  ip: 0000562a8f85edc8 efl: 0000000000010206 cgf: 002b000000000033 erf: 0000000000000004
 trp: 000000000000000e msk: 0000000000000000 cr2: 0000000000000010
[end of stack trace]
Calling _exit(1). Core file will not be generated.

I'm using Linux Mint 18.1 with a 4.10 Kernel.

Cheers

EDIT

As Faheem Mitha pointed out, this could be a hardware issue, although the fact that the laptop shows no other weird behaviors kind of points to software. I will use memtest86 when I can.

One other thing that I found out these files are created in ~/.config/chromium:

Jul  5 10:02 SingletonSocket -> /tmp/.org.chromium.Chromium.vibNiB/SingletonSocket
Jul  5 10:02 SingletonLock -> NP900X3N-2368
Jul  5 10:02 SingletonCookie -> 1648236092507555754

And the output of file Singleton* shows that

SingletonCookie: broken symbolic link to 1648236092507555754
SingletonLock:   broken symbolic link to NP900X3N-2368
SingletonSocket: symbolic link to /tmp/.org.chromium.Chromium.vibNiB/SingletonSocket

I don't know if they are important, but the fact that two of those links are broken and that NP300X3N is my laptop model tell me that they have something to do with the issue.

  • Have you excluded hardware issues? I'd check memory, at least. And are you seeing this kind of behavior with any other apps? Needless to say, this isn't normal behavior. – Faheem Mitha Jul 5 '17 at 15:48
  • @FaheemMitha I'm not really sure how to check for hardware issues related to this. Everything else seems to be working normally and my laptop is pretty new. So it doesn't really look like it's a hardware issue. – TomCho Jul 5 '17 at 16:49
  • The standard test for memory is memtest86. Though the thing takes ages to run. I'm not saying it's a hardware issue, it's just hard to imagine how it could be a software issue. Is your laptop showing any signs of distress? Like overheating? Though if Chromium is the only program showing this issue, it does seem to point away from hardware issues. – Faheem Mitha Jul 5 '17 at 16:51
  • @FaheemMitha Noted. You should check my edit to the question though. Thanks! – TomCho Jul 5 '17 at 17:22
  • For what it's worth I get similar output: faheem@orwell:~/.config/chromium$ file Singleton* SingletonCookie: broken symbolic link to 16641885082069733752 SingletonLock: broken symbolic link to orwell-17228 SingletonSocket: symbolic link to /tmp/.org.chromium.Chromium.gW5UTm/SingletonSocket. And my Chromium is working normally. – Faheem Mitha Jul 5 '17 at 17:25
0

I am having this same issue. It seems the issue is related to the extension system perhaps as when I launch Chromium with extensions disabled, it opens correctly:

chromium-browser --disable-extensions

Hopefully this gets fixed soon, but in the meantime, you should be able to use Chromium as you want to.

  • That appears to work for me too. So this is pretty much a chromium bug, correct? Because I don't remember installing any extension recently. – TomCho Jul 6 '17 at 6:06
  • I saw somewhere it was an update to a default extension for connecting to ChromeCast devices. FWIW, I was able to launch Chromium this morning with no issue. – myesain Jul 6 '17 at 14:39
  • Since yesterday I sometimes can launch it without issues too. But then eventually after some times (maybe hours) it closes again. – TomCho Jul 8 '17 at 19:59
  • By the way, I thought I should mention, I opened an issue here. And I don't have extensions! And even so your --disable-extensions trick works. – TomCho Jul 9 '17 at 6:24
0

Just for completeness: it turns out this was simply a bug that got corrected after a couple of updates from the repository.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.