I'm using kernel 3.3.2-6.fc16.x86_64 and I have a Broadcom 4312.

When I run iwconfig, I get the following:

lo        no wireless extensions.
p2p1      no wireless extensions.

I cannot use wireless, I have to use cable. How can I get my wireless network adapter up and running?

  • 1
    did you have wireless working previously on this computer? previously on Fedora 16? – onefiftyfour Apr 28 '12 at 18:50

Have you tried booting with one of the older kernels?

When you boot, fedora gives you the option of booting from a few prior kernels.

If wireless works from a prior kernel, you can then wait for another kernel update and see if wireless works with that kernel.

  • how to boot with an older kernel, because on grub boot, i see only 3.3 – Noor Apr 28 '12 at 17:39
  • on my machine I have these available:3.3.2-6.fc16.x86_64 , 3.3.2-1.fc16.x86_64 , 3.3.1-5.fc16.x86_64 . They are all 3.3 also. – onefiftyfour Apr 28 '12 at 18:52
  • What Fedora does is to keep older kernels (by default 3). If you just installed, you'll only see one. – vonbrand Jan 24 '13 at 11:12

Some changes happened recently with these drivers. Try to put the firmware bcm43xx-0.fw in/lib/firmware/brcm, if they are not already present there (maybe using symlinks). Try then modprobe brcmsmac.

Or you may wait for the next system update, which hopefully will fix the mess by itself.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.