2

I'm running Debian Jesse with Gnome 3. I've created a ZFS pool named Data and set its mount point to /media/[user]/Data. Below is a screenshot of my /media/[user] folder and the desktop showing how those mount points appear to the system.

screenshot of the current config

Notice:

  • Beta is a Raid
  • Mirror & Backwash are internal drives
  • Data is our ZFS pool, but shows as a removable drive.

That last point is what I'd like to change. As far as I've been told, you simply need to state zfs set mountpoint=/myspecialfolder mypool, however, how the system represents that data appears to be interpreted elsewhere. Mind you, all drives are connected over internal SATA cables, so they're all technically internal drives to begin with.

How do I force the ZFS pool to appear as an internal drive?

  • Does askubuntu.com/questions/70867/… work? – user121391 Jul 5 '17 at 7:15
  • I'm not interested in changing the icon specifically, but rather the way the system interprets the disk. Why is it showing up as a removable? Is this because the mount point is explicit in zpool rather than processed through fstab? I hope that clarifies. – Atriace Jul 5 '17 at 13:25
  • I'm wondering if it's because of the path with "/media". If you want to mount it via the fstab, try setting it as a legacy mount point. zfs set mountpoint=legacy mypool – sleepyweasel Jul 7 '17 at 20:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.